View Issue Details

IDProjectCategoryView StatusLast Update
0006087GNUnetrevocation servicepublic2020-08-14 12:04
Reporterschanzen Assigned Toschanzen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Target Version0.13.0Fixed in Version0.13.0 
Summary0006087: Scrypt parameters do not conform to standard
DescriptionSee https://tools.ietf.org/html/rfc7914#section-6

Currently, we use N=1. But the standard says "larger than 1".
We should increase it to two.

Breaks 0.12 compat.
TagsNo tags attached.

Relationships

child of 0005920 closedschanzen LSD0001 meta issue 
child of 0006324 closedschanzen LSD0001 meta issue 

Activities

schanzen

2020-04-22 17:26

manager   ~0015733

We switched to argon2.

schanzen

2020-08-14 12:04

manager   ~0016615

Closing as resolved since at least 0.13.2

Issue History

Date Modified Username Field Change
2020-02-10 23:47 schanzen New Issue
2020-02-10 23:47 schanzen Status new => assigned
2020-02-10 23:47 schanzen Assigned To => schanzen
2020-02-10 23:47 schanzen Description Updated
2020-02-10 23:47 schanzen Relationship added child of 0005920
2020-04-22 17:26 schanzen Status assigned => resolved
2020-04-22 17:26 schanzen Resolution open => won't fix
2020-04-22 17:26 schanzen Fixed in Version => 0.13.0
2020-04-22 17:26 schanzen Note Added: 0015733
2020-06-01 00:52 Adminknox Relationship added child of 0006324
2020-06-01 00:52 Adminknox Issue cloned: 0006326
2020-08-14 12:04 schanzen Note Added: 0016615
2020-08-14 12:04 schanzen Status resolved => closed