View Issue Details

IDProjectCategoryView StatusLast Update
0005873Talerexchangepublic2020-03-31 16:04
ReporterFlorian Dold Assigned ToMarcello Stanisci  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Summary0005873: design document and implement "legacy" banking API for libeufin and implement wirewatch plugin
DescriptionSome banking APIs do *not* offer us nice, monotonically increasing transaction identifiers. Instead, we can only query a time range of transaction data.

Even worse, new transaction might appear in a time range that we've already queried, so we need to re-query older time ranges, preferably with a lower frequency than querying the newer ones.

With libeufin, we will have a unified interface to query these "legacy" bank interfaces. However, this still doesn't give us a "nice" transaction history like the Taler demo bank gives us.

To allow integration with legacy APIs, we need to
1. Define a HTTP/JSON API between the wirewatch plugin and libeufin for "legacy bank interfaces"
2. Implement a wirewatch plugin for this
3. Implement a "legacy bank interface" for our own demo bank, so we can test the wirewatch plugin.
TagsNo tags attached.

Relationships

related to 0005746 closedChristian Grothoff history query with ranges needs testing 

Activities

Marcello Stanisci

2019-09-04 11:55

viewer   ~0014853

Point number 3 was implemented a while ago (but of course never tested due to the lack of a wire-plugin)!

https://docs.taler.net/core/api-bank.html#get--history-range

Florian Dold

2020-01-07 17:39

manager   ~0015237

This bug report still refers to the old design of libeufin. In the new design, the libeufin nexus service provides a cleaned up transaction history to the exchange.

Issue History

Date Modified Username Field Change
2019-09-04 11:41 Florian Dold New Issue
2019-09-04 11:41 Florian Dold Status new => assigned
2019-09-04 11:41 Florian Dold Assigned To => Marcello Stanisci
2019-09-04 11:55 Marcello Stanisci Note Added: 0014853
2019-09-04 12:03 Marcello Stanisci Relationship added related to 0005746
2020-01-07 17:39 Florian Dold Status assigned => resolved
2020-01-07 17:39 Florian Dold Resolution open => no change required
2020-01-07 17:39 Florian Dold Note Added: 0015237
2020-03-31 16:04 Christian Grothoff Status resolved => closed