View Issue Details

IDProjectCategoryView StatusLast Update
0005518GNUnetwebpagepublic2019-02-28 11:17
Reporterng0Assigned Tong0 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005518: make new website responsive
DescriptionI've already worked on this a bit, but some page main content boxes were
left out.
The standard should be to be responsive by default in the template, not to optimize the pages later on for it.
Tagswebsite

Activities

ng0

2019-01-27 16:02

developer   ~0013481

Repo: https://gnunet.org/git/www.git

ng0

2019-01-27 16:08

developer   ~0013482

Sub issue, which should be fixed by responsiveness:

- architecture-page:
  * The graph image does not really display well on small screens.

By 'not well' I mean it is too big.

catonano

2019-01-30 02:25

reporter   ~0013513

I tried to shrunk the browser window in every page and it seems that every page already is responsive

What do you mean with: "some page main content boxes were
left out" ?

I can't find anything that has been left out of being responsive

ng0

2019-01-30 12:05

developer   ~0013521

Hm. I moved this from the TODO file in the repository to Mantis.
Maybe the only thing I did not fix was 0005523

ng0

2019-01-30 19:34

developer   ~0013525

Imo the only relevant issue why not to close this is because we have the architecture-page image.

catonano

2019-01-31 06:48

reporter   ~0013531

ok

that image is confusing and unreadable, a smaller version would be even worse

Probably a svg version could do

But I don't now clearly where to start from, for that

Christian Grothoff

2019-02-14 12:02

manager   ~0013747

catonano: not sure which image you are talking about, but gnunet-arch-full.svg is an SVG. Also, this is basically *generated* using Graphviz (dot) from gnunet/doc/handbook/images/structure.dot.

Simplified versions can also be easily derived by simplifying the dot input there.

But maybe you're talking about a different image?

catonano

2019-02-14 12:20

reporter   ~0013754

Christian

no I was referring to the gnunet-arch-full.svg file

it's a bit dense and also quite large

I thought that svg images would srihnk with the browser window but it seems this one doesn't

again I don't know where to start from

ng0

2019-02-15 16:26

developer   ~0013791

The move to bootstrap 4 fixed this.
Images will get some more changes in later commits.

Issue History

Date Modified Username Field Change
2019-01-27 16:00 ng0 New Issue
2019-01-27 16:02 ng0 Note Added: 0013481
2019-01-27 16:08 ng0 Note Added: 0013482
2019-01-29 16:01 catonano Tag Attached: website
2019-01-30 02:25 catonano Note Added: 0013513
2019-01-30 12:05 ng0 Note Added: 0013521
2019-01-30 19:34 ng0 Note Added: 0013525
2019-01-30 19:35 ng0 Category other => webpage
2019-01-30 19:36 ng0 Target Version => 0.11.0
2019-01-31 06:48 catonano Note Added: 0013531
2019-02-04 00:55 Christian Grothoff Target Version 0.11.0 => 0.11.1
2019-02-14 12:02 Christian Grothoff Note Added: 0013747
2019-02-14 12:02 Christian Grothoff Assigned To => Christian Grothoff
2019-02-14 12:02 Christian Grothoff Status new => feedback
2019-02-14 12:02 Christian Grothoff Assigned To Christian Grothoff => ng0
2019-02-14 12:20 catonano Note Added: 0013754
2019-02-15 16:26 ng0 Status feedback => resolved
2019-02-15 16:26 ng0 Resolution open => fixed
2019-02-15 16:26 ng0 Fixed in Version => 0.11.0
2019-02-15 16:26 ng0 Note Added: 0013791
2019-02-15 18:17 Christian Grothoff Product Version => SVN HEAD
2019-02-15 18:17 Christian Grothoff Target Version 0.11.1 => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed