View Issue Details

IDProjectCategoryView StatusLast Update
0005523GNUnetwebpagepublic2019-02-28 11:17
Reporterng0Assigned Tong0 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.11.0Fixed in Version0.11.0 
Summary0005523: new website: about page is not responsive
DescriptionFix this:

about-page:
  ...
  * Either provide no image or upload your images!

The whole page assumes a static resolution size at the moment.
Tagswebsite

Activities

catonano

2019-01-30 02:27

reporter   ~0013514

Where is such "about page" ?

I can't find it

ng0

2019-01-30 11:58

developer   ~0013520

Last edited: 2019-01-30 12:02

View 2 revisions

Too bad we can't link to a language neutral version. Here's the default one:

https://stage.gnunet.org/en/about.html

You will notice the reported behavior when you start reducing the size or use the webdeveloper view of your browser to simulate very small smartphones. It works up until a certain width, afterwards the responsiveness is broken, for the lack of a better word.

I could imagine falling back to reducing the image size by percentage and once we no longer have space for 2 images side by side, display the images (or rather: the entries) in a list-like behavior, a 1xN grid where N is the length (say we have 20 members and the default displays a 5x5 grid it would then be a 1x20 grid).

ng0

2019-01-30 12:13

developer   ~0013522

semi-related: instead of having no icon, people without images attached could get the new gnunet symbol as an icon/avatar. I will add this part now.

ng0

2019-01-30 12:20

developer   ~0013523

Last edited: 2019-01-30 12:35

View 3 revisions

To be honest, it looks weird: https://d.n0.is/pub/jpg/2019-01-30-112125_1920x1080_scrot.png ... So having a scaling space would probably be nicer.

(I keep forgetting that we are working with bootstrap4, I am used to implementing the methods myself from scratch without a framework)

ng0

2019-01-30 12:50

developer   ~0013524

Last edited: 2019-01-30 12:55

View 2 revisions

catonano, do you think that https://gnunet.org/git/www.git/commit/?id=0c4826847d3e2c2c5511d621fd5b40b655b34d53 is good enough for now?
There's an awful lot amount of whitespace, so maybe we still need some tweaks.
All common phones look good enough, tablet size (iPad, Kindle Fire HDX, ...) start reacting to the bootstrap4 size, so we already have the break to 1 item per grid row, leading to acceptable(?) white space.
Personally I don't care much for tablets and don't know what people consider as normal view with tablets for websites.

catonano

2019-01-31 07:30

reporter   ~0013532

I think it's ok the way it is, after your fix

As far as I'm concerned, you can close this one

ng0

2019-02-06 19:09

developer   ~0013618

Christian, why 0.11.1? Can you tell me why the website is first considered a major requirement for the next major version, and now it's the next minor version?

Christian Grothoff

2019-02-06 19:14

manager   ~0013619

The website itself is a major requirements, but not every bell or whistle for the new website is critical. There are simply things I'm happy to be fixed post-release (but if they are done for 0.11, that's of course great). I would just not hold up the release because one sub-page is not responsive.

ng0

2019-02-06 22:02

developer   ~0013621

okay, thanks.
this page was just an example because I saw many items simply moved to 0.11.1
this item is more or less done, closing it now.

Issue History

Date Modified Username Field Change
2019-01-27 16:19 ng0 New Issue
2019-01-29 16:00 catonano Tag Attached: website
2019-01-30 02:27 catonano Note Added: 0013514
2019-01-30 11:58 ng0 Note Added: 0013520
2019-01-30 12:02 ng0 Note Edited: 0013520 View Revisions
2019-01-30 12:13 ng0 Note Added: 0013522
2019-01-30 12:20 ng0 Note Added: 0013523
2019-01-30 12:23 ng0 Note Edited: 0013523 View Revisions
2019-01-30 12:35 ng0 Note Edited: 0013523 View Revisions
2019-01-30 12:50 ng0 Note Added: 0013524
2019-01-30 12:55 ng0 Note Edited: 0013524 View Revisions
2019-01-30 19:33 ng0 Category other => webpage
2019-01-31 07:30 catonano Note Added: 0013532
2019-02-04 00:57 Christian Grothoff Target Version => 0.11.1
2019-02-06 19:09 ng0 Note Added: 0013618
2019-02-06 19:09 ng0 Assigned To => Christian Grothoff
2019-02-06 19:09 ng0 Status new => feedback
2019-02-06 19:14 Christian Grothoff Note Added: 0013619
2019-02-06 22:02 ng0 Note Added: 0013621
2019-02-06 22:02 ng0 Status feedback => assigned
2019-02-06 22:04 ng0 Assigned To Christian Grothoff => ng0
2019-02-06 22:04 ng0 Status assigned => resolved
2019-02-06 22:04 ng0 Resolution open => fixed
2019-02-06 22:04 ng0 Fixed in Version => 0.11.0
2019-02-06 22:04 ng0 Target Version 0.11.1 => 0.11.0
2019-02-28 11:17 Christian Grothoff Status resolved => closed