View Issue Details

IDProjectCategoryView StatusLast Update
0005469Talerdeployment and operationspublic2018-12-07 18:46
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityhighSeverityfeatureReproducibilityN/A
Status assignedResolutionreopened 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005469: deploy taler-auditor-httpd
DescriptionWe need to deploy the (new) auditor's HTTPD. It should run on auditor.[test/demo].taler.net. The "/" page itself can/should be hijacked to continue to point to the current page.

Furthermore, before calling 'taler-auditor-sign', we must now run 'taler-auditor-exchange' to add the exchange's master public key and base-URL to the auditor's database.

Please ask me if any of this is unclear.
TagsNo tags attached.

Relationships

has duplicate 0005461 closedMarcello Stanisci auditor should run alongside test and demo deployment 

Activities

Marcello Stanisci

2018-11-29 17:20

manager   ~0013370

I just checked the code, and 'taler-auditor-sign' has the "-m" option that's there for the sole purpose of fetching a exchange's key.

Are you sure we have to call that 'taler-auditor-exchange' tool anyway?

Christian Grothoff

2018-11-29 17:24

manager   ~0013371

Yes, that's the only one that adds (or removes) the exchange's URL and master public key to the auditor's database.

Marcello Stanisci

2018-11-29 17:51

manager   ~0013372

11212f1 @deployment.git adds this invocation.

Note:

right now, we are mixing the exchange's and auditor's
deployment; that means that in one script we create the exchange
keys, get them signed by the auditor, and also register the
exchange key+url at the auditor. This will never happen IRL,
but I assume it is okay to get the demo running.

Marcello Stanisci

2018-11-29 18:03

manager   ~0013373

Given that "/" is also served (statically taking content from auditor.git), this one can be closed now.

Christian Grothoff

2018-11-29 18:21

manager   ~0013374

Well, in reality those steps will have to be interleaved properly as part of the business processes between exchange and auditor. Doing so in the deployment script is fine.

Marcello Stanisci

2018-12-07 18:46

manager   ~0013392

Reopening since the 'demo' side doesn't have the auditor deployed yet (what's just missing are a few Nginx rules); this is because we don't want to touch it until next release.

Issue History

Date Modified Username Field Change
2018-11-04 17:43 Christian Grothoff New Issue
2018-11-04 17:43 Christian Grothoff Status new => assigned
2018-11-04 17:43 Christian Grothoff Assigned To => Marcello Stanisci
2018-11-29 17:20 Marcello Stanisci Note Added: 0013370
2018-11-29 17:24 Christian Grothoff Note Added: 0013371
2018-11-29 17:51 Marcello Stanisci Note Added: 0013372
2018-11-29 18:03 Marcello Stanisci Status assigned => resolved
2018-11-29 18:03 Marcello Stanisci Resolution open => fixed
2018-11-29 18:03 Marcello Stanisci Note Added: 0013373
2018-11-29 18:21 Christian Grothoff Note Added: 0013374
2018-11-29 18:21 Christian Grothoff Fixed in Version => 0.6
2018-12-06 13:19 Marcello Stanisci Relationship added child of 0005461
2018-12-07 18:46 Marcello Stanisci Status resolved => new
2018-12-07 18:46 Marcello Stanisci Resolution fixed => reopened
2018-12-07 18:46 Marcello Stanisci Note Added: 0013392
2018-12-07 18:46 Marcello Stanisci Status new => assigned
2018-12-07 18:48 Marcello Stanisci Relationship deleted child of 0005461
2018-12-07 18:51 Marcello Stanisci Relationship added has duplicate 0005461