View Issue Details

IDProjectCategoryView StatusLast Update
0004563Talerdeployment and operationspublic2019-09-16 09:19
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.0 
Target Version0.6Fixed in Version0.6 
Summary0004563: deployment does not fix versions for GNUnet, MHD; potential to break demo
DescriptionWhile we're always using the master branch in test and the stable branch in demo for taler components, GNUnet and MHD is always compiled from master, even in demo@taler.net.

This means that demo breaks once we re-enable automatic builds and GNUnet makes a backwards incompatible crypto change.
TagsNo tags attached.

Relationships

has duplicate 0004716 closedChristian Grothoff deployment uses non-fixed SVN version of GNUnet and libmicrohttpd 

Activities

Christian Grothoff

2016-06-08 22:09

manager   ~0010878

Best method I can think of addressing this is to really just make a GNUnet release "soon" and then always require that Taler releases (& demo) only depends on released GNUnet versions, possibly forcing us to make more frequent GNUnet releases, which might not be a bad thing anyway.

Marcello Stanisci

2019-06-24 10:36

manager   ~0014570

Last edited: 2019-06-24 10:36

View 2 revisions

Demo shall never break because (1) it is always installed from the latest release that depends on GNUnet/MHD masters, and (2) once installed it stays untouched (including GNUnet/MHD!) forever.

Will close this.

Issue History

Date Modified Username Field Change
2016-06-07 11:29 Florian Dold New Issue
2016-06-08 22:09 Christian Grothoff Note Added: 0010878
2016-06-11 21:58 Christian Grothoff Status new => confirmed
2016-06-11 21:58 Christian Grothoff Product Version => 0.0
2016-06-11 21:58 Christian Grothoff Target Version => 0.3
2016-10-10 08:31 Christian Grothoff Target Version 0.3 => 0.5
2017-03-18 23:55 Christian Grothoff Relationship added has duplicate 0004716
2017-04-09 00:13 Christian Grothoff Target Version 0.5 =>
2019-06-24 10:36 Marcello Stanisci Note Added: 0014570
2019-06-24 10:36 Marcello Stanisci Note Edited: 0014570 View Revisions
2019-06-24 10:37 Marcello Stanisci Assigned To => Marcello Stanisci
2019-06-24 10:37 Marcello Stanisci Status confirmed => resolved
2019-06-24 10:37 Marcello Stanisci Resolution open => fixed
2019-09-16 09:19 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:19 Christian Grothoff Target Version => 0.6