View Issue Details

IDProjectCategoryView StatusLast Update
0004051Talerwallet (WebExtensions)public2019-09-01 18:44
ReporterMarcello StanisciAssigned ToFlorian Dold 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.7Fixed in Version 
Summary0004051: support two levels of bank integration for creating reserves
DescriptionThe mint should support two ways of starting the creation of a reserve:

1) in a bank which supports Taler (T-bank)
2) non T-banks (N-bank)

In both cases, the user will get a prompt where he can indicate which mint
he wants to create this reserve in. For every chosen mint, an internal DB will
store data such as: | currency | base URL | rank |

every time a user chooses some mint, its rank should be raised by one.

The difference between T-banks and N-banks is the following:

T-banks will trigger this dialog as well as will prevent the user to manually
copy-paste relevant data into the SEPA webform. See (*)

N-banks instead are rather passive: they do NOT trigger anything in the wallet
but just gets relevant data manually pasted into their SEPA webform. The user
manually pushes the 'create reserve' dialog. Furthermore, the 'create reserve'
dialog with N-banks should ask the user to insert the desired amount also, in order
to allow the wallet to 'poll' the reserve to see if all the money have been transferred.
(*) That is not the case with T-banks since the wallet can fetch this information
directly from the SEPA webform DOM.

A nice feature to have in the known mints dialog is the autocompletion of the
mint base URL.
TagsNo tags attached.

Relationships

duplicate of 0005774 assignedFlorian Dold add support for creating a reserve from within the wallet and topping it up via payto QR code 
has duplicate 0004628 assignedFlorian Dold wallet does not support withdraw with loose bank integration 

Activities

Florian Dold

2019-09-01 18:44

manager   ~0014832

This is a duplicate of 0005774

Issue History

Date Modified Username Field Change
2015-11-12 11:26 Marcello Stanisci New Issue
2015-11-12 11:26 Marcello Stanisci Status new => assigned
2015-11-12 11:26 Marcello Stanisci Assigned To => Marcello Stanisci
2015-11-17 14:52 Christian Grothoff Severity minor => feature
2015-11-17 14:52 Christian Grothoff Summary multi mint on 'create reserve' => support two levels of bank integration for creating reserves
2016-01-22 13:31 Marcello Stanisci Assigned To Marcello Stanisci => Florian Dold
2016-01-22 13:31 Marcello Stanisci Category wallet (browser-based) => wallet (WebExtensions)
2016-01-22 23:27 Christian Grothoff Target Version 0.1 => 0.3
2016-03-20 21:53 Torsten Grothoff Issue cloned: 0004309
2016-10-10 08:32 Christian Grothoff Relationship added has duplicate 0004628
2017-03-02 08:07 Christian Grothoff Target Version 0.3 => 0.4
2017-04-09 00:23 Christian Grothoff Target Version 0.4 => 0.7
2019-09-01 18:44 Florian Dold Status assigned => closed
2019-09-01 18:44 Florian Dold Resolution open => duplicate
2019-09-01 18:44 Florian Dold Note Added: 0014832
2019-09-01 18:44 Florian Dold Relationship added duplicate of 0005774