View Issue Details

IDProjectCategoryView StatusLast Update
0003229GNUnettransport servicepublic2014-01-27 09:10
ReporterSree Harsha TotakuraAssigned ToMatthias Wachs 
PriorityimmediateSeveritycrashReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product VersionSVN HEAD 
Target Version0.10.1Fixed in Version 
Summary0003229: crash at plugin_transport_tcp.c:1265; SVN revision 31613
DescriptionCore was generated by `/usr/local/lib/gnunet/libexec/gnunet-service-transport -c /home/totakura/.confi'.
Program terminated with signal 6, Aborted.
#0 0x00007f5b0f7561d5 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0 0x00007f5b0f7561d5 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007f5b0f759388 in __GI_abort () at abort.c:90
#2 0x00007f5b0fde15a1 in GNUNET_abort () at common_logging.c:289
#3 0x00007f5b0e0d3c1a in tcp_plugin_send (cls=0x1a9baf0, session=0x1ac52a0, msgbuf=0x7ffff9cf72c0 "",
    msgbuf_size=16, priority=4294967295, to=..., cont=0x0, cont_cls=0x0) at plugin_transport_tcp.c:1265
#4 0x000000000041010f in send_session_connect (na=0x1ab1fd8) at gnunet-service-transport_neighbours.c:1702
#5 0x00000000004115b5 in handle_test_blacklist_cont (cls=0x1ab1cc0, peer=0x1ab2028, result=1)
    at gnunet-service-transport_neighbours.c:2064
#6 0x0000000000408550 in GST_blacklist_test_allowed (peer=0x1ab2028, transport_name=0x7ffff9cf7692 "udp",
    cont=0x410cb1 <handle_test_blacklist_cont>, cont_cls=0x1ab1cc0) at gnunet-service-transport_blacklist.c:735
#7 0x0000000000411b40 in check_blacklist (peer=0x1ab2028, ts=..., address=0x7ffff9cf7590, session=0x1ac52a0)
    at gnunet-service-transport_neighbours.c:2156
#8 0x0000000000412f0e in GST_neighbours_switch_to_address (peer=0x7ffff9cf7590, address=0x7ffff9cf7590,
    session=0x1ac52a0, ats=0x7ffff9cf7678, ats_count=2, bandwidth_in=..., bandwidth_out=...)
    at gnunet-service-transport_neighbours.c:2446
#9 0x0000000000405c2d in ats_request_address_change (cls=0x0, address=0x7ffff9cf7590, session=0x0,
    bandwidth_out=..., bandwidth_in=..., ats=0x7ffff9cf7678, ats_count=2) at gnunet-service-transport.c:762
#10 0x00007f5b1065549f in process_ats_message (cls=0x1a990d0, msg=0x7ffff9cf7640) at ats_api_scheduling.c:659
#11 0x00007f5b0fdde01a in receive_task (cls=0x1a98990, tc=0x7ffff9cf7760) at client.c:595
#12 0x00007f5b0fe16d2e in run_ready (rs=0x1a976e0, ws=0x1aaa030) at scheduler.c:595
#13 0x00007f5b0fe175bc in GNUNET_SCHEDULER_run (task=0x7f5b0fe23748 <service_task>, task_cls=0x7ffff9cf7b00)
    at scheduler.c:817
#14 0x00007f5b0fe254b7 in GNUNET_SERVICE_run (argc=3, argv=0x7ffff9cf7d88, service_name=0x41f4e4 "transport",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405ff7 <run>, task_cls=0x0) at service.c:1490
#15 0x000000000040679a in main (argc=3, argv=0x7ffff9cf7d88) at gnunet-service-transport.c:1008
(gdb)
Additional Information(gdb) bt full
#0 0x00007f5b0f7561d5 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
        resultvar = 0
        pid = 30723
        selftid = 30723
#1 0x00007f5b0f759388 in __GI_abort () at abort.c:90
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x56, sa_sigaction = 0x56}, sa_mask = {__val = {0,
              140737384509952, 140029096021397, 140733193388033, 0, 140028818751489, 140029077912808,
              140029054499497, 140737384509952, 86, 140029096047109, 1, 18446744073709551615, 0, 140029081720800,
              140029081714816}}, sa_flags = 279287552, sa_restorer = 0x7f5b0fac5be0 <_IO_helper_jumps>}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2 0x00007f5b0fde15a1 in GNUNET_abort () at common_logging.c:289
No locals.
#3 0x00007f5b0e0d3c1a in tcp_plugin_send (cls=0x1a9baf0, session=0x1ac52a0, msgbuf=0x7ffff9cf72c0 "",
    msgbuf_size=16, priority=4294967295, to=..., cont=0x0, cont_cls=0x0) at plugin_transport_tcp.c:1265
        plugin = 0x1a9baf0
        pm = 0x7f5b0fe2b9d8 <GNUNET_TIME_absolute_hton+24>
        __FUNCTION__ = "tcp_plugin_send"
#4 0x000000000041010f in send_session_connect (na=0x1ab1fd8) at gnunet-service-transport_neighbours.c:1702
        papi = 0x1a9b850
        connect_msg = {header = {size = 4096, type = 30465}, reserved = 0, timestamp = {
            abs_value_us__ = 13847317330673861632}}
        __FUNCTION__ = "send_session_connect"
#5 0x00000000004115b5 in handle_test_blacklist_cont (cls=0x1ab1cc0, peer=0x1ab2028, result=1)
    at gnunet-service-transport_neighbours.c:2064
        bcc = 0x1ab1cc0
        n = 0x1ab1fc0
        __FUNCTION__ = "handle_test_blacklist_cont"
#6 0x0000000000408550 in GST_blacklist_test_allowed (peer=0x1ab2028, transport_name=0x7ffff9cf7692 "udp",
    cont=0x410cb1 <handle_test_blacklist_cont>, cont_cls=0x1ab1cc0) at gnunet-service-transport_blacklist.c:735
---Type <return> to continue, or q <return> to quit---
        bc = 0x0
        __FUNCTION__ = "GST_blacklist_test_allowed"
#7 0x0000000000411b40 in check_blacklist (peer=0x1ab2028, ts=..., address=0x7ffff9cf7590, session=0x1ac52a0)
    at gnunet-service-transport_neighbours.c:2156
        bcc = 0x1ab1cc0
        bc = 0x4edfabe94ccdc
        __FUNCTION__ = "check_blacklist"
#8 0x0000000000412f0e in GST_neighbours_switch_to_address (peer=0x7ffff9cf7590, address=0x7ffff9cf7590,
    session=0x1ac52a0, ats=0x7ffff9cf7678, ats_count=2, bandwidth_in=..., bandwidth_out=...)
    at gnunet-service-transport_neighbours.c:2446
        n = 0x1ab1fc0
        papi = 0x1a9ae80
        __FUNCTION__ = "GST_neighbours_switch_to_address"
#9 0x0000000000405c2d in ats_request_address_change (cls=0x0, address=0x7ffff9cf7590, session=0x0,
    bandwidth_out=..., bandwidth_in=..., ats=0x7ffff9cf7678, ats_count=2) at gnunet-service-transport.c:762
        bw_in = 4278
        bw_out = 4278
        __FUNCTION__ = "ats_request_address_change"
#10 0x00007f5b1065549f in process_ats_message (cls=0x1a990d0, msg=0x7ffff9cf7640) at ats_api_scheduling.c:659
        sh = 0x1a990d0
        m = 0x7ffff9cf7640
        atsi = 0x7ffff9cf7678
        plugin_address = 0x7ffff9cf7688 ""
        plugin_name = 0x7ffff9cf7692 "udp"
        plugin_address_length = 10
        plugin_name_length = 4
        ats_count = 2
        address = {peer = {public_key = {
              q_y = "M\372\363\367\307rwm\220\353/\320\003U\257\317E\271\035\071\334b\321&\356\270\327\001\205U\217", <incomplete sequence \314>}}, transport_name = 0x7ffff9cf7692 "udp", address = 0x7ffff9cf7688, address_length = 10}
---Type <return> to continue, or q <return> to quit---
        s = 0x0
        __FUNCTION__ = "process_ats_message"
        session_id = 0
#11 0x00007f5b0fdde01a in receive_task (cls=0x1a98990, tc=0x7ffff9cf7760) at client.c:595
        client = 0x1a98990
        handler = 0x7f5b10654e64 <process_ats_message>
        cmsg = 0x1b714a0
        handler_cls = 0x1a990d0
        msize = 86
        mbuf = 0x7ffff9cf7640 ""
        msg = 0x7ffff9cf7640
        __FUNCTION__ = "receive_task"
#12 0x00007f5b0fe16d2e in run_ready (rs=0x1a976e0, ws=0x1aaa030) at scheduler.c:595
        p = GNUNET_SCHEDULER_PRIORITY_DEFAULT
        pos = 0x1c21aa0
        tc = {reason = GNUNET_SCHEDULER_REASON_TIMEOUT, read_ready = 0x1a976e0, write_ready = 0x1aaa030}
        __FUNCTION__ = "run_ready"
#13 0x00007f5b0fe175bc in GNUNET_SCHEDULER_run (task=0x7f5b0fe23748 <service_task>, task_cls=0x7ffff9cf7b00)
    at scheduler.c:817
        rs = 0x1a976e0
        ws = 0x1aaa030
        timeout = {rel_value_us = 0}
        ret = 5
        shc_int = 0x1aaa0e0
        shc_term = 0x1a97af0
        shc_quit = 0x1a97c70
        shc_hup = 0x1a97d30
        shc_pipe = 0x1a97bb0
        last_tr = 471910
        busy_wait_warning = 0
---Type <return> to continue, or q <return> to quit---
        pr = 0x1aa51c0
        c = 0 '\000'
        __FUNCTION__ = "GNUNET_SCHEDULER_run"
#14 0x00007f5b0fe254b7 in GNUNET_SERVICE_run (argc=3, argv=0x7ffff9cf7d88, service_name=0x41f4e4 "transport",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x405ff7 <run>, task_cls=0x0) at service.c:1490
        err = 0
        ret = 3
        cfg_fn = 0x1a96720 "~/.config/gnunet.conf"
        opt_cfg_fn = 0x1a96870 "/home/totakura/.config/gnunet.conf"
        loglev = 0x0
        logfile = 0x0
        do_daemonize = 0
        i = 4218871
        skew_offset = 140029098048728
        skew_variance = 0
        clock_offset = 4208176
        sctx = {cfg = 0x1a96740, server = 0x1a98080, addrs = 0x0, service_name = 0x41f4e4 "transport",
          task = 0x405ff7 <run>, task_cls = 0x0, v4_denied = 0x0, v6_denied = 0x0, v4_allowed = 0x1aa31d0,
          v6_allowed = 0x1aaa750, my_handlers = 0x1aa9cf0, addrlens = 0x0, lsocks = 0x1a975a0, shutdown_task = 4,
          timeout = {rel_value_us = 18446744073709551615}, ret = 1, ready_confirm_fd = -1, require_found = 1,
          match_uid = 0, match_gid = 1, options = GNUNET_SERVICE_OPTION_NONE}
        cfg = 0x1a96740
        xdg = 0x0
        service_options = {{shortName = 99 'c', name = 0x7f5b0fe32e2d "config",
            argumentHelp = 0x7f5b0fe32e34 "FILENAME",
            description = 0x7f5b0fe32e40 "use configuration file FILENAME", require_argument = 1,
            processor = 0x7f5b0fe050e3 <GNUNET_GETOPT_set_string>, scls = 0x7ffff9cf7bb8}, {shortName = 100 'd',
            name = 0x7f5b0fe32e60 "daemonize", argumentHelp = 0x0,
            description = 0x7f5b0fe32e70 "do daemonize (detach from terminal)", require_argument = 0,
            processor = 0x7f5b0fe050b6 <GNUNET_GETOPT_set_one>, scls = 0x7ffff9cf7ba4}, {shortName = 104 'h',
---Type <return> to continue, or q <return> to quit---
            name = 0x7f5b0fe32e94 "help", argumentHelp = 0x0, description = 0x7f5b0fe32e99 "print this help",
            require_argument = 0, processor = 0x7f5b0fe04b7d <GNUNET_GETOPT_format_help_>, scls = 0x0}, {
            shortName = 76 'L', name = 0x7f5b0fe32ea9 "log", argumentHelp = 0x7f5b0fe32ead "LOGLEVEL",
            description = 0x7f5b0fe32eb8 "configure logging to use LOGLEVEL", require_argument = 1,
            processor = 0x7f5b0fe050e3 <GNUNET_GETOPT_set_string>, scls = 0x7ffff9cf7bb0}, {shortName = 108 'l',
            name = 0x7f5b0fe32eda "logfile", argumentHelp = 0x7f5b0fe32ee2 "LOGFILE",
            description = 0x7f5b0fe32ef0 "configure logging to write logs to LOGFILE", require_argument = 1,
            processor = 0x7f5b0fe050e3 <GNUNET_GETOPT_set_string>, scls = 0x7ffff9cf7ba8}, {shortName = 118 'v',
            name = 0x7f5b0fe32f1b "version", argumentHelp = 0x0,
            description = 0x7f5b0fe32f23 "print the version number", require_argument = 0,
            processor = 0x7f5b0fe04b37 <GNUNET_GETOPT_print_version_>, scls = 0x7f5b0fe32f3c}, {
            shortName = 0 '\000', name = 0x0, argumentHelp = 0x0, description = 0x0, require_argument = 0,
            processor = 0x0, scls = 0x0}}
        __FUNCTION__ = "GNUNET_SERVICE_run"
#15 0x000000000040679a in main (argc=3, argv=0x7ffff9cf7d88) at gnunet-service-transport.c:1008
No locals.
(gdb)
TagsNo tags attached.

Relationships

has duplicate 0003232 closedMatthias Wachs transport segfault (running system) in TCP 

Activities

Matthias Wachs

2014-01-20 10:32

manager   ~0008003

ATS instructed neighbours to switch to tco address without session,
neighbours has obtained a session from the plugin and after the blacklist check tries to send a CONNECT but now the sesion is invalid...

Matthias Wachs

2014-01-20 10:36

manager   ~0008004

GST_blacklist_test_allowed is synchronous if no bl clients are active, otherwise a task is scheduled... so if it is asynchronous, the session could have been removed in between...

Matthias Wachs

2014-01-20 10:38

manager   ~0008005

Did this issues occur when running gnunet or in a test?
Do you know if a blacklist client was active?
How to reproduce?

This issue will be solved by 0003262 anyway...

Sree Harsha Totakura

2014-01-20 19:07

developer   ~0008010

This occured while running gnunet. Not is a test. There was no blacklist client as far as I remember.

I didn't look out for this crash again, so no particular steps for reproducing it.

Matthias Wachs

2014-01-21 09:09

manager   ~0008020

Could give me some additional information:
- Did it occur while running a peer?
- How long did it run before the crash happened?
- Which plugins did you have enabled?
- Was your peer reachable from the Internet?

Sree Harsha Totakura

2014-01-21 09:21

developer   ~0008021

Sorry, I don't remember the configuration at the time of the crash. But I do remember that the crash occurred while running my peer and it was reachable from the Internet.

Matthias Wachs

2014-01-27 09:08

manager   ~0008032

Last edited: 2014-01-27 09:09

View 3 revisions

Had a peer with revision 32024 running for ~ 3 days with:

[transport]
plugins = udp tcp https_client https_server

No crashes (coredumps) after that time ...

Please give me feedback if it happens again and re-open the bug. At the moment I cannot reproduce and the bug is quite old does not appear on my system...

Perhaps it was related to a bug like 0003245 crashing transport and after that a invalid outdated session was given to transport...

Issue History

Date Modified Username Field Change
2013-12-20 23:13 Sree Harsha Totakura New Issue
2013-12-20 23:13 Sree Harsha Totakura Status new => assigned
2013-12-20 23:13 Sree Harsha Totakura Assigned To => Matthias Wachs
2013-12-22 01:40 Christian Grothoff Relationship added has duplicate 0003232
2013-12-22 01:40 Christian Grothoff Priority normal => immediate
2013-12-22 01:40 Christian Grothoff Target Version => 0.10.0
2013-12-23 12:34 Sree Harsha Totakura Assigned To Matthias Wachs => Sree Harsha Totakura
2013-12-23 19:06 Christian Grothoff Target Version 0.10.0 => 0.10.1
2013-12-23 19:08 Christian Grothoff Assigned To Sree Harsha Totakura => Matthias Wachs
2014-01-20 10:32 Matthias Wachs Note Added: 0008003
2014-01-20 10:36 Matthias Wachs Note Added: 0008004
2014-01-20 10:38 Matthias Wachs Note Added: 0008005
2014-01-20 10:38 Matthias Wachs Status assigned => feedback
2014-01-20 10:38 Matthias Wachs Resolution open => unable to reproduce
2014-01-20 19:07 Sree Harsha Totakura Note Added: 0008010
2014-01-20 19:07 Sree Harsha Totakura Status feedback => assigned
2014-01-21 09:09 Matthias Wachs Note Added: 0008020
2014-01-21 09:09 Matthias Wachs Status assigned => feedback
2014-01-21 09:21 Sree Harsha Totakura Note Added: 0008021
2014-01-21 09:21 Sree Harsha Totakura Status feedback => assigned
2014-01-27 09:08 Matthias Wachs Note Added: 0008032
2014-01-27 09:09 Matthias Wachs Note Edited: 0008032 View Revisions
2014-01-27 09:09 Matthias Wachs Note Edited: 0008032 View Revisions
2014-01-27 09:10 Matthias Wachs Status assigned => closed