View Issue Details

IDProjectCategoryView StatusLast Update
0003262GNUnettransport servicepublic2014-04-08 16:41
ReporterMatthias WachsAssigned ToMatthias Wachs 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003262: Do blacklist check before switching address
DescriptionAt the moment in transport neighbours on an outbound address switch the address is first switched and then a blacklist check is performed. This is a bad idea because it increases complexity in the state machine.

The blacklist check should be performed BEFORE switching addresses. If the check is OK, the address is switched, otherwise the address is destroyed in ATS and the current address is kept.

TagsNo tags attached.

Activities

Matthias Wachs

2014-03-26 16:12

manager   ~0008158

Implemented in rev 32795:

All blacklist checks are now down before information are given to neighbours
Therefore the neighbour state machine was simplified since all *_BLACKLIST states could be removed.

Blacklist checks are now performed:
- Before a the TRY_CONNECT request is given to neighbours
- Before an address switch is triggered
- Before a CONNECT message is given to neighbours

Issue History

Date Modified Username Field Change
2014-01-09 13:59 Matthias Wachs New Issue
2014-01-09 13:59 Matthias Wachs Status new => assigned
2014-01-09 13:59 Matthias Wachs Assigned To => Matthias Wachs
2014-03-26 16:12 Matthias Wachs Note Added: 0008158
2014-03-26 16:12 Matthias Wachs Status assigned => resolved
2014-03-26 16:12 Matthias Wachs Resolution open => fixed
2014-04-08 16:39 Christian Grothoff Product Version => SVN HEAD
2014-04-08 16:39 Christian Grothoff Fixed in Version => 0.10.1
2014-04-08 16:39 Christian Grothoff Target Version => 0.10.1
2014-04-08 16:41 Christian Grothoff Status resolved => closed