View Issue Details

IDProjectCategoryView StatusLast Update
0008940GNUnetdocumentationpublic2024-06-14 06:20
Reporternoe Assigned Tot3sserakt  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Platformx86_64OSGNU Guix 
Product Version0.21.2 
Summary0008940: Getting started instructions are outdated
DescriptionHi,

I wanted to try out Gnunet, so after installing the package I followed the instructions at https://www.gnunet.org/en/use.html.

I could not get it working on my machine, or on my friend's arch linux. It seems the tutorial is severely outdated, the gnunet-peerinfo command doesn't exist, and using gnunet-core without arguments complains that it needs arguments.

Same thing for the manual at https://docs.gnunet.org/latest/users/start.html.

Ignoring these issues, me and my friend couldn't get gnunet to start properly, there's always errors in the logs. I've attached mine.

Could it be possible to update the manual?
Thanks in advance
TagsNo tags attached.

Relationships

has duplicate 0008941 resolvedschanzen Documentation is outdated 

Activities

schanzen

2024-06-13 21:14

administrator   ~0022601

the command you want is not simply

gnunet-core --show-connections

see also gnunet-core --help

gnunet-peerinfo does indeed no longer exist.
The websites should be removed and/or migrated to the handbook.

I updated the handbook start page.

noe

2024-06-13 21:28

reporter   ~0022602

Thanks, the new start page is better. Sorry for the duplicate issue the website showed me an error when I posted so I thought it didn't send.

noe

2024-06-13 21:31

reporter   ~0022603

Do you have the equivalent to 'gnunet-peerinfo -gn' and 'gnunet-peerinfo -p' please ?

schanzen

2024-06-13 21:45

administrator   ~0022604

Nope. Those functions do not exist anymore because the service no longer exists.
gnunet-peerinfo -s was replaced by gnunet-core --show-identity

If you need the functionality, we may be able to design an alterntive that achieves what you need.

noe

2024-06-13 22:14

reporter   ~0022605

Ok, thanks for the help. I just wanted to try it to connect directly to some other peer as I'm having issues connecting to the network, I don't think it would have worked anyways since the issues seem to be from TRANSPORT.

schanzen

2024-06-14 06:20

administrator   ~0022608

The functions that are still documented on the home page (we need to fix that asap) may be useful to be honest.
But they just dont have a replacement _right now_.

To connect two peers you control that are actually reachable, it makes sense to have one set up as a hostlist server and the other connect to that hostlist (see docs for host server/client config).

Issue History

Date Modified Username Field Change
2024-06-13 17:32 noe New Issue
2024-06-13 21:12 schanzen Relationship added has duplicate 0008941
2024-06-13 21:14 schanzen Note Added: 0022601
2024-06-13 21:14 schanzen Assigned To => schanzen
2024-06-13 21:14 schanzen Status new => assigned
2024-06-13 21:28 noe Note Added: 0022602
2024-06-13 21:31 noe Note Added: 0022603
2024-06-13 21:45 schanzen Note Added: 0022604
2024-06-13 21:48 schanzen Assigned To schanzen => t3sserakt
2024-06-13 22:14 noe Note Added: 0022605
2024-06-14 06:20 schanzen Note Added: 0022608