View Issue Details

IDProjectCategoryView StatusLast Update
0006143libmicrohttpdbuild systempublic2020-04-09 09:49
ReporterdkgAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.70 
Target Version0.9.71Fixed in Version0.9.71 
Summary0006143: "make -j4 check" fails in src/testzzuf
DescriptionWhen make is running in parallel mode, the tests in src/testzzuf fail
Steps To Reproducemake -j4 check
Additional InformationThis failure happens on 0.90.66 as well.

I noticed this because i'm trying to modernize the packaging we use to ship libmicrohttpd in debian, and modern debhelper prefers to run make in parallel mode.

Sorry i don't know enough about the microhttpd test suite to offer a patch to fix this! But it is generally a good idea for the project to be able to build and test in parallel anyway.

Thanks for libmicrohttpd!
TagsNo tags attached.

Activities

dkg

2020-03-31 22:56

reporter   ~0015479

sorry, this appears to be a dup of 0006117

Christian Grothoff

2020-04-09 09:49

manager   ~0015601

No problem, closing as dupe.

Issue History

Date Modified Username Field Change
2020-03-31 22:37 dkg New Issue
2020-03-31 22:56 dkg Note Added: 0015479
2020-04-09 09:49 Christian Grothoff Note Added: 0015601
2020-04-09 09:49 Christian Grothoff Assigned To => Christian Grothoff
2020-04-09 09:49 Christian Grothoff Status new => closed
2020-04-09 09:49 Christian Grothoff Resolution open => duplicate
2020-04-09 09:49 Christian Grothoff Fixed in Version => 0.9.71
2020-04-09 09:49 Christian Grothoff Target Version => 0.9.71