View Issue Details

IDProjectCategoryView StatusLast Update
0006117libmicrohttpdbuild systempublic2020-03-14 16:11
ReporterbeberkingAssigned Tobeberking 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.70 
Target Version0.9.71Fixed in Version0.9.71 
Summary0006117: zzuf testsuite fails
DescriptionAll zzuf tests fail, while they do not fail with MHD 0.9.68 on the same box.

Please find src/testzzuf/test-suite.log attached.
TagsNo tags attached.

Activities

beberking

2020-03-08 10:44

developer  

test-suite.log (1,582 bytes)

Christian Grothoff

2020-03-10 21:18

manager   ~0015443

Eh, did you install 'socat'? We don't test for its presence, but if zzuf is there but socat is missing, the tests fail for me _because_ socat is missing.

So if this is true, all we need to fix is check for 'socat' in addition to 'zzuf'.

Christian Grothoff

2020-03-10 21:19

manager   ~0015444

Actually, we do check for 'socat', just not if you run the tests directly from within src/testzzuf/. Could that be the issue?

beberking

2020-03-14 15:31

developer   ~0015451

Hi Christian,

I checked, and socat is installed properly. I double checked and I found a clue:
make check works, while make -j2 check fails (-j2 is the default in Debian).

If this is expected, we just need to add the .NOTPARALLEL target in src/testzzuf/Makefile.

Hope this helps,
Bertrand

Christian Grothoff

2020-03-14 16:10

manager   ~0015452

Makes sense. Fixed in 70781455..2e8a4f8b

Issue History

Date Modified Username Field Change
2020-03-08 10:44 beberking New Issue
2020-03-08 10:44 beberking File Added: test-suite.log
2020-03-10 21:18 Christian Grothoff Note Added: 0015443
2020-03-10 21:19 Christian Grothoff Note Added: 0015444
2020-03-10 21:19 Christian Grothoff Assigned To => beberking
2020-03-10 21:19 Christian Grothoff Status new => feedback
2020-03-14 15:31 beberking Note Added: 0015451
2020-03-14 16:10 Christian Grothoff Status feedback => resolved
2020-03-14 16:10 Christian Grothoff Resolution open => fixed
2020-03-14 16:10 Christian Grothoff Fixed in Version => 0.9.71
2020-03-14 16:10 Christian Grothoff Note Added: 0015452
2020-03-14 16:11 Christian Grothoff Target Version => 0.9.71