View Issue Details

IDProjectCategoryView StatusLast Update
0005849Talerbank (demonstrator)public2019-08-23 16:01
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0005849: allow all test cases to be automatically run via "./manage.py test"
DescriptionCurrently there is some environment variable hackery in the Makefile going on to run all our tests.

This setup should be part of the test cases, they should be self-contained and we should be able to run them via the normal test runner.
TagsNo tags attached.

Activities

Florian Dold

2019-08-23 15:44

manager   ~0014804

Especially the config files should be located by the tests themselves!

Florian Dold

2019-08-23 16:01

manager   ~0014805

Actually, because of the way django works, we really need to run "./manage.py test" multiple times. Closing this.

Issue History

Date Modified Username Field Change
2019-08-23 15:42 Florian Dold New Issue
2019-08-23 15:42 Florian Dold Status new => assigned
2019-08-23 15:42 Florian Dold Assigned To => Marcello Stanisci
2019-08-23 15:44 Florian Dold Note Added: 0014804
2019-08-23 16:01 Florian Dold Status assigned => closed
2019-08-23 16:01 Florian Dold Resolution open => no change required
2019-08-23 16:01 Florian Dold Note Added: 0014805