View Issue Details

IDProjectCategoryView StatusLast Update
0005810Talerdeployment and operationspublic2020-10-03 14:10
ReporterMarcello Stanisci Assigned ToMarcello Stanisci  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0005810: Survey reserve from 'demo' needs automation
DescriptionThe tip reserve from demo suffers from the following two problems:

1) it is not automatically topped up.

2) it is not automatically "refreshed". In particular, even if the reserve did
  not expired and was replenished with money, the merchant backend still
  needs to receive a "/tip-query" call in order to update its database and flag
  the reserve as active. If we miss this step, we get that 2702 error.

I have manually patched the situation by:

1) log in as the active demo user (demo-blue now)
2) source activate && taler-deployment-top-reserve
3) visit survey.demo.taler.net, and *click* "survey stats"
TagsNo tags attached.

Activities

davidak

2019-12-19 04:16

reporter   ~0015189

Is this the reason for the demo beeing broken?

Taler Survey Demo
An Error Occurred
Backend returned error status

The backend returned status code 404.

Backend Response:

{'code': 1151, 'hint': 'Reserve unknown at exchange'}

MS

2020-08-25 17:07

manager   ~0016763

This issue got obsoleted by the latest protocol refactoring. The main point is that there is no need to invoke the "/tip-query" endpoint to mark a tip-reserve as active. After paying for it, the merchant knows already about a new tip-reserve.

However, at this moment the 'demo' deployment is still running the old code.

'test', on the other hand, runs the new code and has a dedicated worker that updates its tip-reserves.

MS

2020-08-25 17:10

manager   ~0016764

Last edited: 2020-08-25 17:11

View 2 revisions

As the title suggests, this bug waits for 'demo' to be upgraded to the latest code AND a tip-reserve topper worker to be pointed to it.

Note also that such worker (+ systemd config files) is implemented (as part of the bootstrap script) already.

MS

2020-08-28 17:31

manager   ~0016787

The worker is active now and demo runs Taler 8.0.0-dev.1.

Issue History

Date Modified Username Field Change
2019-07-20 12:19 Marcello Stanisci New Issue
2019-12-19 04:16 davidak Note Added: 0015189
2020-07-23 21:46 Christian Grothoff Assigned To => Christian Grothoff
2020-07-23 21:46 Christian Grothoff Status new => assigned
2020-07-24 16:53 Christian Grothoff Assigned To Christian Grothoff => Marcello Stanisci
2020-08-25 17:07 MS Note Added: 0016763
2020-08-25 17:10 MS Note Added: 0016764
2020-08-25 17:11 MS Note Edited: 0016764 View Revisions
2020-08-28 17:31 MS Status assigned => resolved
2020-08-28 17:31 MS Resolution open => fixed
2020-08-28 17:31 MS Note Added: 0016787
2020-10-03 14:08 Christian Grothoff Fixed in Version => 0.8
2020-10-03 14:10 Christian Grothoff Target Version => 0.8