View Issue Details

IDProjectCategoryView StatusLast Update
0005809gnunet-gtkgnunet-setuppublic2024-02-11 11:44
Reporterred Assigned ToChristian Grothoff  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version0.11.5 
Target Version0.11.6Fixed in Version0.11.6 
Summary0005809: Errors installing gnunet-gtk on Debian 9
DescriptionThe instructions on the website for installing GNUnet on Debian 9 with GUI give error messages. Here is what the error looks like:


user@GNUnet:~/gnunet_installation/gnunet-gtk$ make -j$(nproc || echo -n 1)

make: *** No targets specified and no makefile found. Stop.

user@GNUnet:~/gnunet_installation/gnunet-gtk$ sudo make install

make: *** No rule to make target 'install'. Stop.

user@GNUnet:~/gnunet_installation/gnunet-gtk$


Perhaps there is a missing step? Without GUI support not a lot of people are willing to tinker with it, and Debian users certainly make a potentially large user-base.
Steps To ReproduceSimply follow instructions for GNUnet installation on Debian with GUI support. I have tested on several machines and I always get the same error.
TagsError, website

Activities

nikita

2019-07-20 11:37

developer   ~0014707

Can you please give more detail about your build environment (the output gnunet-bugreport) and what your exact steps were?

This:

Option 3: gnunet-gtk

Installing the Gtk+-based graphical user interface can be done on top of either the production or development installation.
$ sudo apt install libgtk-3-dev libgladeui-dev libunique-dev libqrencode-dev $ cd ~/gnunet_installation/gnunet-gtk
$ ./bootstrap
$ export CFLAGS="-g -Wall -O0"
$ ./configure --prefix=$GNUNET_PREFIX --with-gnunet=$GNUNET_PREFIX
$ make -j$(nproc || echo -n 1)
$ sudo make install


should be enough as it creates the Makefiles before processing them with make. It is what the website looks like for me.

Christian Grothoff

2019-07-21 10:58

manager   ~0014714

Looks to me like you skipped (at least) the "configure" step from the instructions. The instructions are correct (I just double-checked).

Issue History

Date Modified Username Field Change
2019-07-20 07:36 red New Issue
2019-07-20 07:36 red Tag Attached: Error
2019-07-20 07:36 red Tag Attached: gnunet-gtk
2019-07-20 07:36 red Tag Attached: website
2019-07-20 11:37 nikita Note Added: 0014707
2019-07-21 10:58 Christian Grothoff Note Added: 0014714
2019-07-21 10:58 Christian Grothoff Assigned To => Christian Grothoff
2019-07-21 10:58 Christian Grothoff Status new => resolved
2019-07-21 10:58 Christian Grothoff Resolution open => no change required
2019-07-21 10:58 Christian Grothoff Fixed in Version => 0.11.5
2019-07-24 20:41 Christian Grothoff Target Version => 0.11.6
2019-07-24 20:41 Christian Grothoff Fixed in Version 0.11.5 => 0.11.6
2019-07-24 20:42 Christian Grothoff Status resolved => closed
2024-02-11 11:44 Christian Grothoff Tag Detached: gnunet-gtk