View Issue Details

IDProjectCategoryView StatusLast Update
0005794GNUnetgnunet-setuppublic2019-07-24 20:42
ReporterxrsAssigned Tolurchi 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSArchlinuxOS Versionedge
Product VersionSVN HEAD 
Target Version0.11.6Fixed in Version0.11.6 
Summary0005794: multi user setup not working properly
DescriptionWhen using some of the CLI tools under a normal user they hang.

E.g.:
> gnunet-identity -d
or
> gnunet-arm -I

One reason could be that no runtime was created for the user. There exists the gnunet-gnunet-runtime and gnunet-system-runtime under /tmp.

Lurchi seems to have similar problems and concluded that the multi user setup did not work for him.

Another example, maybe different problem, but this works under single user setup:
> gnunet-publish text.txt
Error publishing: Can not index file `/home/xrs/text.txt': .
.
Steps To ReproduceInstall everything as described in Chapter 4.1 to 4.7.1. in https://docs.gnunet.org/#Installing-GNUnet.

There are two configs:
- /etc/gnunet.conf
- ~/.config/gnunet.conf

Run gnunet instance under user gnunet.
Run CLI tools under normal user.
Additional InformationAdding configs and some logs.
TagsNo tags attached.

Activities

xrs

2019-07-06 17:02

manager  

gnunet-idedentity.log (32,375 bytes)
gnunet-publish.log (54,762 bytes)
gnunet-2019-07-06.log (95,579 bytes)
gnunet.user.conf (165 bytes)
gnunet.conf (314 bytes)

lurchi

2019-07-07 02:22

developer   ~0014653

In NixOS, the multi-user setup now works for me (except for the problem described in https://bugs.gnunet.org/view.php?id=5795). The runtime directory for my user is created as soon as I run

gnunet-arm -s

as my user. But in your case it seems that is not possible. The log you attached is from the user services, correct? Is there suspicious output in the system services logs?

xrs

2019-07-07 11:43

manager   ~0014654

---> Start `gnunet-arm -s` as normal user.
Maybe this information was missing! I didn't know I had to start gnunet-arm also as normal user as well.

In the handbook in chapter 4.7.1 it says only in the last sentence:
"For the multi-user setup first the system services need to be started as the system user, i.e. the user gnunet needs to execute gnunet-arm -s. This should be done by the system’s init system."

Is this correct?

xrs

2019-07-07 11:47

manager   ~0014655

@lurchi: To answere your questions. Yes, it is possible to start as normal user. Yes, the logs are from the user services without having started gnunet-arm under normal user. I supposed running gnunet-arm under system user "gnunet" was enought. No suspicous output in the system service logs.

lurchi

2019-07-07 12:32

developer   ~0014656

The information that normal users have to run gnunet-arm -s is in the manual, but hidden in the "Config Leftovers" chapter which we should slowly eliminate. I added it in the "Checking the installation chapter" too:

https://git.gnunet.org/gnunet.git/commit/?id=9ffc488dd37caebe53ce4af86fb1a3f0eacc7c7c

Can this issue be closed?

Issue History

Date Modified Username Field Change
2019-07-06 17:02 xrs New Issue
2019-07-06 17:02 xrs File Added: gnunet-idedentity.log
2019-07-06 17:02 xrs File Added: gnunet-publish.log
2019-07-06 17:02 xrs File Added: gnunet-2019-07-06.log
2019-07-06 17:02 xrs File Added: gnunet.user.conf
2019-07-06 17:02 xrs File Added: gnunet.conf
2019-07-07 02:22 lurchi Note Added: 0014653
2019-07-07 11:43 xrs Note Added: 0014654
2019-07-07 11:47 xrs Note Added: 0014655
2019-07-07 12:32 lurchi Note Added: 0014656
2019-07-07 13:02 xrs Assigned To => lurchi
2019-07-07 13:02 xrs Status new => assigned
2019-07-07 13:03 xrs Status assigned => resolved
2019-07-07 13:03 xrs Resolution open => fixed
2019-07-24 20:41 Christian Grothoff Fixed in Version => 0.11.6
2019-07-24 20:42 Christian Grothoff Status resolved => closed