View Issue Details

IDProjectCategoryView StatusLast Update
0005795GNUnetnamestore servicepublic2019-07-24 20:42
Reporterlurchi Assigned ToChristian Grothoff  
Status closedResolutionfixed 
Product VersionGit master 
Target Version0.11.6Fixed in Version0.11.6 
Summary0005795: zonemaster cannot access namestore in multi-user setup
DescriptionWhen I run GNUnet in the multi-user setup (system services started as user gnunet, user services started as my user) I see this in the logs of the system services:

Jul 06 20:58:07-984198 util-31247 DEBUG Asked to $-expand $GNUNET_USER_RUNTIME_DIR/gnunet-service-namestore.sock
Jul 06 20:58:07-984230 util-31247 DEBUG Split into `GNUNET_USER_RUNTIME_DIR' and `gnunet-service-namestore.sock' with default (null)
Jul 06 20:58:07-984258 util-31247 DEBUG Asked to $-expand ${TMPDIR:-${TMP:-/tmp}}/gnunet-${USERHOME:-${USER:-user}}-runtime/
Jul 06 20:58:07-984283 util-31247 DEBUG Split into `TMPDIR' and `/gnunet-${USERHOME:-${USER:-user}}-runtime/' with default ${TMP:-/tmp}
Jul 06 20:58:07-984307 util-31247 DEBUG Asked to $-expand ${TMP:-/tmp}
Jul 06 20:58:07-984329 util-31247 DEBUG Split into `TMP' and `' with default /tmp
Jul 06 20:58:07-984353 util-31247 DEBUG Asked to $-expand /tmp
Jul 06 20:58:07-984443 util-31247 DEBUG Doesn't start with $ - not expanding
Jul 06 20:58:07-984479 util-31247 DEBUG Asked to $-expand ${USERHOME:-${USER:-user}}-runtime/
Jul 06 20:58:07-984503 util-31247 DEBUG Split into `USERHOME' and `-runtime/' with default ${USER:-user}
Jul 06 20:58:07-984529 util-31247 DEBUG Asked to $-expand ${USER:-user}
Jul 06 20:58:07-984552 util-31247 DEBUG Split into `USER' and `' with default user
Jul 06 20:58:07-984671 util-client-31247 DEBUG Failed to establish connection to `namestore', no further addresses to try, will try again in 262 s.

This output is generated by the zonemaster service (I enabled debug output there). The result is that records that I add using ``gnunet-namestore`` are not published in GNS. I saw that the namestore service is run per user, so how can zonemaster, which runs once per system, access it? When I run only one namestore service per system, by changing the two options below, everything works as expected.

UNIXPATH = $GNUNET_RUNTIME_DIR/gnunet-service-namestore.sock

Is it ok to run the namestore service like this? We should change it in the default config then.
Steps To Reproduce./bootstrap
export CFLAGS="-g -Wall -O0"
./configure --enable-logging=verbose --disable-documentation
sudo useradd --system --home-dir /var/lib/gnunet --create-home gnunet
sudo groupadd gnunetdns
make && sudo make install
usermod -aG gnunet <myuser>
# log out, log in

# create config files in /var/lib/gnunet/.config/gnunet.conf and /home/<myuser>/.config/gnunet.conf
# as both user gnunet and <myuser>:
gnunet-arm -s

Additional Informationsystem config:


user config:
TagsNo tags attached.


Christian Grothoff

2019-07-12 21:03

manager   ~0014668

Zonemaster should run per user, but wasn't configured to do so. Fixed in aca547d7e..1b7caeb5a

Issue History

Date Modified Username Field Change
2019-07-07 02:03 lurchi New Issue
2019-07-07 02:04 lurchi Description Updated
2019-07-07 02:04 lurchi Additional Information Updated
2019-07-07 02:06 lurchi Description Updated
2019-07-07 02:07 lurchi Description Updated
2019-07-07 02:08 lurchi Description Updated
2019-07-11 21:03 t3sserakt Assigned To => Christian Grothoff
2019-07-11 21:03 t3sserakt Status new => feedback
2019-07-12 21:03 Christian Grothoff Note Added: 0014668
2019-07-12 21:04 Christian Grothoff Status feedback => resolved
2019-07-12 21:04 Christian Grothoff Resolution open => fixed
2019-07-12 21:04 Christian Grothoff Fixed in Version => 0.11.6
2019-07-12 21:04 Christian Grothoff Target Version => 0.11.6
2019-07-24 20:42 Christian Grothoff Status resolved => closed