View Issue Details

IDProjectCategoryView StatusLast Update
0005678Talerotherpublic2019-09-16 09:19
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionnot fixable 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005678: mailhook fails for large commits
DescriptionThe mailhook fails for large commits, with two problems:
* the generated mail is too large
* some python module can't be imported

This shouldn't happen. Even tough huge commits are rare, they are necessary sometimes (e.g. to check in larger dependencies).
Additional Informationremote: Resolving deltas: 100% (7857/7857), done.
remote: refs/heads/master 0000000000000000000000000000000000000000 4e707c841bb479f81289b17f3ca932fa7ed5ffe0
remote: Commit 4e707c841bb479f81289b17f3ca932fa7ed5ffe0 was signed by a GPG key: gpg: Signature made Wed 03 Apr 2019 03:46:03 PM CEST
remote: Commit 71e285b94c7edaa43aa8115965cf5a36b8e0f80a was signed by a GPG key: gpg: Signature made Wed 03 Apr 2019 03:45:59 PM CEST
remote: Commit 7dadf9356b4f3f4137ce982ea5bb960283116e9a was signed by a GPG key: gpg: Signature made Wed 03 Apr 2019 03:45:54 PM CEST
remote: Sending notification emails to: gnunet-svn@gnu.org


remote: postdrop: warning: uid=1002: File too large
remote: sendmail: fatal: gnunet@gnunet.org(1002): message file too big
remote: Exception 'CommandError' raised. Please report this as a bug to
remote: https://github.com/git-multimail/git-multimail/issues
remote: with the information below:
remote:
remote: git-multimail version 1.4.0
remote: Python version 3.5.3 (default, Sep 27 2018, 17:25:39)
remote: [GCC 6.3.0 20170516]
remote: Traceback (most recent call last):
remote: File "hooks/post-receive.h00-post-receive.multimail", line 4214, in main
remote: run_as_post_receive_hook(environment, mailer)
remote: File "hooks/post-receive.h00-post-receive.multimail", line 3669, in run_as_post_receive_hook
remote: push.send_emails(mailer, body_filter=environment.filter_body)
remote: File "hooks/post-receive.h00-post-receive.multimail", line 3626, in send_emails
remote: rev.recipients,
remote: File "hooks/post-receive.h00-post-receive.multimail", line 2024, in send
remote: raise CommandError(self.command, retcode)
remote: CommandError: Command "/usr/sbin/sendmail -oi -t -f gnunet@gnunet.org" failed with retcode 75
remote:
remote:
remote: Traceback (most recent call last):
remote: File "hooks/post-receive.h01-post-receive.buildbot", line 28, in <module>
remote: from future.utils import iteritems
remote: ImportError: No module named 'future'
TagsNo tags attached.

Activities

Marcello Stanisci

2019-06-25 23:10

manager   ~0014595

Tried locally, the following two shell commands should fix it.

# postconf -e message_size_limit=200000000
# service postfix restart

The question is, are 200MB a good value *in general* ?

Also, I couldn't reproduce the ImportError, since 'future' is actually not imported (anymore).

Marcello Stanisci

2019-06-26 15:26

manager   ~0014597

Last edited: 2019-06-26 15:27

View 2 revisions

The 200000000 limit was obtained by trying to notifying the whole wallet-webex.git history via e-mail.

However, even by setting this value on one controlled server, it is not expectable that *other* e-mail servers will pass that big amount of data through.

CG suggests to set this value to 16MB, which is a threshold that other email servers will allow too (or at least, it is the one for gnunet.org).

Marcello Stanisci

2019-06-27 23:20

manager   ~0014612

4fa6e73 (gv-maintenance.git) message_size_limit is set to 16MB.

Marcello Stanisci

2019-06-27 23:22

manager   ~0014613

For changes bigger than 16MB the mail-hook will just fail!

Issue History

Date Modified Username Field Change
2019-04-03 15:53 Florian Dold New Issue
2019-06-25 23:10 Marcello Stanisci Note Added: 0014595
2019-06-26 15:26 Marcello Stanisci Note Added: 0014597
2019-06-26 15:27 Marcello Stanisci Note Edited: 0014597 View Revisions
2019-06-27 23:20 Marcello Stanisci Note Added: 0014612
2019-06-27 23:22 Marcello Stanisci Assigned To => Marcello Stanisci
2019-06-27 23:22 Marcello Stanisci Status new => resolved
2019-06-27 23:22 Marcello Stanisci Resolution open => not fixable
2019-06-27 23:22 Marcello Stanisci Note Added: 0014613
2019-09-16 09:19 Christian Grothoff Product Version => SVN HEAD
2019-09-16 09:19 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:19 Christian Grothoff Target Version => 0.6