View Issue Details

IDProjectCategoryView StatusLast Update
0005666Talerbank (demonstrator)public2019-04-10 20:51
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005666: bank and wire plugin should support date-based transaction histories
DescriptionSome banks do not support querying only the latest transaction after some other transaction. In fact, a transaction with an *earlier* date might be reported in a second transaction list query, which was not present in the first.

In practice, a banking API could give us a transaction that happened 5 days ago only today, even if we already got transactions confirmed from yesterday. Unfortunately we *need* to support this kind of awfully designed API, since that is what some banks offer.

In turn, both the bank and the wire plugin API (!!) should support this alternate interface, while *also* supporting the faster one based on monotonically increasing transaction numbers.

In summary, the bank and wire plugin must support querying for transactions based on a date range. The wire plugins also must ignore if duplicated transactions are reported.
TagsNo tags attached.

Activities

Marcello Stanisci

2019-04-04 18:27

manager   ~0014258

The Python Bank implements such date-based histories: 4a131f632f936eb49adb7f608851. Will leave this open until fakebank does the same.

Marcello Stanisci

2019-04-10 19:08

manager   ~0014286

This commit: 5c496633092de5ebccd43e, adds the "/history-range" API to the fakebank + testing library.

Note that both the pybank and fakebank have tests for the new feature, but not "a lot". However, we'll have many occasions to test this API once the wirewatch will be able to speak to them, so I'm going to close this bug!

Issue History

Date Modified Username Field Change
2019-03-22 20:18 Florian Dold New Issue
2019-03-22 20:18 Florian Dold Status new => assigned
2019-03-22 20:18 Florian Dold Assigned To => Marcello Stanisci
2019-04-04 18:27 Marcello Stanisci Note Added: 0014258
2019-04-10 19:08 Marcello Stanisci Note Added: 0014286
2019-04-10 19:08 Marcello Stanisci Status assigned => resolved
2019-04-10 19:08 Marcello Stanisci Resolution open => fixed
2019-04-10 20:51 Christian Grothoff Product Version => SVN HEAD
2019-04-10 20:51 Christian Grothoff Fixed in Version => 0.6
2019-04-10 20:51 Christian Grothoff Target Version => 0.6