View Issue Details

IDProjectCategoryView StatusLast Update
0005652GNUnetGNSpublic2019-04-11 19:18
Reporteric.rbowAssigned ToChristian Grothoff 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.11.0 
Target Version0.11.4Fixed in Version0.11.4 
Summary0005652: Default config delegates .fr but there's noone to respond
DescriptionThis is a problem when you want to enable GNS system-wide and still be able to visit `.fr` sites.
Steps To Reproduce$ gnunet-gns -u nic.fr
...
(wait forever)

TagsNo tags attached.

Activities

ng0

2019-03-20 23:52

developer   ~0014226

Can you provide more information?

I myself can't help you but someone else will be able to help with more info given.

ic.rbow

2019-03-21 09:41

reporter   ~0014229

There is a delegation entry in default gns config file:

    src/gns/gns.conf.in
    29:.fr = TFDAXBXMAN40MCG4E8Y9Y1C6D16JCMDPH2VMD30KMB92SECEMYGG

When I try to resolve a name through it I can't get a reply from anyone.
As if there's no node that serves this public key and its entries are expired by now or evicted from the name caches.

That means when I enable DNS interception or using GNS proxy I lose the ability to visit .fr sites.

The problem is exacerbated by difficulty of removing that entry (for a newcomer).
You can't `gnunet-configure` it out, because setting it to an empty string still blocking the DNS fallback.
You'll have to find the shared default configs directory and remove it from there.

Christian Grothoff

2019-04-11 19:18

manager   ~0014290

I've removed this in Git master now. And yes, we should only add entries there if we actually have the deployment properly life...

Issue History

Date Modified Username Field Change
2019-03-16 18:49 ic.rbow New Issue
2019-03-20 23:52 ng0 Note Added: 0014226
2019-03-21 09:41 ic.rbow Note Added: 0014229
2019-04-11 19:18 Christian Grothoff Note Added: 0014290
2019-04-11 19:18 Christian Grothoff Assigned To => Christian Grothoff
2019-04-11 19:18 Christian Grothoff Status new => resolved
2019-04-11 19:18 Christian Grothoff Resolution open => fixed
2019-04-11 19:18 Christian Grothoff Fixed in Version => 0.11.4
2019-04-11 19:18 Christian Grothoff Product Version => 0.11.0
2019-04-11 19:18 Christian Grothoff Target Version => 0.11.4