View Issue Details

IDProjectCategoryView StatusLast Update
0005565Talerexchangepublic2019-02-18 15:35
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005565: exchange cherry picking test fails (again), 8/10 keys returned
DescriptionFeb 14 13:49:46-355822 test-exchange-api-cherry-picking-new-35175 DEBUG Running command `keys-serialization'
Feb 14 13:49:46-355826 test-exchange-api-cherry-picking-new-35175 DEBUG Running batched command: check-freshest-keys
Feb 14 13:49:46-355830 test-exchange-api-cherry-picking-new-35175 INFO cmd `check-freshest-keys' (ip: 1), key generation: 8
Feb 14 13:49:46-355834 test-exchange-api-cherry-picking-new-35175 ERROR Assertion failed at testing_api_cmd_check_keys.c:141.
Feb 14 13:49:46-355839 test-exchange-api-cherry-picking-new-35175 ERROR Got 8 keys in step check-freshest-keys, expected 10
Feb 14 13:49:46-355847 test-exchange-api-cherry-picking-new-35175 ERROR Failed at command `keys-serialization'
Feb 14 13:49:46-355852 test-exchange-api-cherry-picking-new-35175 ERROR Batch is at command `check-freshest-keys'
TagsNo tags attached.

Activities

Marcello Stanisci

2019-02-14 18:20

manager   ~0013780

I can't reproduce this either. Try to 'git clean -fdx' in your local copy and then try again. You migth have some ancient key that interferes with the logic..

Christian Grothoff

2019-02-14 21:26

manager   ~0013784

I did the git clean -fdx, same result :-(

Christian Grothoff

2019-02-15 14:24

manager   ~0013790

After careful inspection of the logic, the right answer is that 8 DKs are returned as the first 2 are expired at this point. Not sure why the testcase used to pass (maybe expiration was not properly implemented?), but with 8 DKs the test now passes.

Issue History

Date Modified Username Field Change
2019-02-14 13:54 Christian Grothoff New Issue
2019-02-14 13:54 Christian Grothoff Status new => assigned
2019-02-14 13:54 Christian Grothoff Assigned To => Christian Grothoff
2019-02-14 13:54 Christian Grothoff Assigned To Christian Grothoff =>
2019-02-14 13:54 Christian Grothoff Status assigned => confirmed
2019-02-14 18:20 Marcello Stanisci Note Added: 0013780
2019-02-14 21:26 Christian Grothoff Note Added: 0013784
2019-02-15 14:24 Christian Grothoff Assigned To => Christian Grothoff
2019-02-15 14:24 Christian Grothoff Status confirmed => resolved
2019-02-15 14:24 Christian Grothoff Resolution open => fixed
2019-02-15 14:24 Christian Grothoff Fixed in Version => 0.6
2019-02-15 14:24 Christian Grothoff Note Added: 0013790