View Issue Details

IDProjectCategoryView StatusLast Update
0005542Talerbank (demonstrator)public2019-02-12 23:18
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005542: bank assertion failure reported on twitter
Descriptionhttps://twitter.com/davidak/status/1086430279911256064
TagsNo tags attached.

Activities

Marcello Stanisci

2019-02-05 14:39

manager   ~0013602

Theoretically, it's all "okay": with numbers too big a assert failure happens, and that's what happened here. OF COURSE, this is not the right way to react to it, and needs to be handled properly.

Christian Grothoff

2019-02-05 15:46

manager   ~0013603

Yes, we should (1) test first and generate a nice(r) error message, and (2) deploy the bank without infinite negative money (is this because 0.5 didn't have the limit implemented?) so that such extreme balances can't easily be produced.

Marcello Stanisci

2019-02-05 16:35

manager   ~0013604

e5e6d7c1c4852757e29481 hot-fixes (1). It's already deployed, so you can try. As of (2), we deliberately opted for infinite negative balance for the bank (0.5 does have limit implemented), I suspect because we award 100 kudos to new users and it was just easier to do this way.

Of course we can award the 100 kudos to the first N users who register after a new release, and avoid the infinite limit for the bank; but I'm not sure that's worth doing this ("thanks" to those infinite limits we can discover new bugs.)

Marcello Stanisci

2019-02-05 16:42

manager   ~0013605

Changing to "solved" by the way, as this strictly speaking is.

Issue History

Date Modified Username Field Change
2019-02-04 22:29 Christian Grothoff New Issue
2019-02-04 22:29 Christian Grothoff Status new => assigned
2019-02-04 22:29 Christian Grothoff Assigned To => Marcello Stanisci
2019-02-05 14:39 Marcello Stanisci Note Added: 0013602
2019-02-05 15:46 Christian Grothoff Note Added: 0013603
2019-02-05 16:35 Marcello Stanisci Note Added: 0013604
2019-02-05 16:42 Marcello Stanisci Note Added: 0013605
2019-02-05 16:43 Marcello Stanisci Status assigned => resolved
2019-02-05 16:43 Marcello Stanisci Resolution open => fixed
2019-02-12 23:18 Christian Grothoff Fixed in Version => 0.6