View Issue Details

IDProjectCategoryView StatusLast Update
0005484Talerauditorpublic2019-01-08 19:11
ReporterMarcello StanisciAssigned ToChristian Grothoff 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005484: Database crash - foreign key "violation".
DescriptionThis happens even after a reset of both exchanges and auditor tables.

Nov 26 11:29:22-200535 taler-auditor-4692 DEBUG Analyzing coins
* First analysis using this auditor, starting audit from scratch
Nov 26 11:29:22-204455 pq-4692 ERROR Query `auditor_balance_summary_insert' failed with result: insert or update on table "auditor_balance_summary" violates foreign key constraint "master_pub_ref"/Key (master_pub)=(\xdd46afd1d5bab825721e46767e266f17e04243090114d7727a3cd287f16d05f9) is not present in table "auditor_exchanges"./ERROR: insert or update on table "auditor_balance_summary" violates foreign key constraint "master_pub_ref"
DETAIL: Key (master_pub)=(\xdd46afd1d5bab825721e46767e266f17e04243090114d7727a3cd287f16d05f9) is not present in table "auditor_exchanges".
/PGRES_FATAL_ERROR/ERROR: insert or update on table "auditor_balance_summary" violates foreign key constraint "master_pub_ref"
DETAIL: Key (master_pub)=(\xdd46afd1d5bab825721e46767e266f17e04243090114d7727a3cd287f16d05f9) is not present in table "auditor_exchanges".

Steps To Reproducejust run:

$ taler-auditor.
Additional InformationHeppens locally on my machine.
TagsNo tags attached.

Activities

Marcello Stanisci

2018-11-30 22:05

manager   ~0013375

Could just get this error on Tripwire too.

Christian Grothoff

2018-12-01 17:10

manager   ~0013376

Ok, admittedly the error message ought to be improved, but I think you get this because you did not use taler-auditor-exchange first (or not correctly). Basically, the DB complains that the exchange's master public key isn't yet in the table.

Leave this bug open for me to fix the UX, but running taler-auditor-exchange should unblock you.

Marcello Stanisci

2018-12-04 16:03

manager   ~0013385

It did :-)

Christian Grothoff

2019-01-08 19:11

manager   ~0013449

Nicer error message added in 3ed5db97..feec0d49

Issue History

Date Modified Username Field Change
2018-11-26 11:43 Marcello Stanisci New Issue
2018-11-26 11:43 Marcello Stanisci Status new => assigned
2018-11-26 11:43 Marcello Stanisci Assigned To => Christian Grothoff
2018-11-26 11:46 Marcello Stanisci Steps to Reproduce Updated View Revisions
2018-11-26 11:46 Marcello Stanisci Additional Information Updated View Revisions
2018-11-30 22:05 Marcello Stanisci Note Added: 0013375
2018-12-01 17:10 Christian Grothoff Note Added: 0013376
2018-12-04 16:00 Marcello Stanisci Relationship added child of 0005461
2018-12-04 16:03 Marcello Stanisci Note Added: 0013385
2018-12-07 18:44 Marcello Stanisci Relationship deleted child of 0005461
2019-01-08 19:11 Christian Grothoff Note Added: 0013449
2019-01-08 19:11 Christian Grothoff Status assigned => resolved
2019-01-08 19:11 Christian Grothoff Resolution open => fixed
2019-01-08 19:11 Christian Grothoff Fixed in Version => 0.6
2019-01-08 19:11 Christian Grothoff Product Version => SVN HEAD
2019-01-08 19:11 Christian Grothoff Target Version => 0.6