View Issue Details

IDProjectCategoryView StatusLast Update
0005406Talerotherpublic2018-09-15 11:06
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version 
Target Version0.6Fixed in Version0.6 
Summary0005406: Ambiguous wire transfer cancellation const.
DescriptionTaler now has only one const value to identify cancelled wire transfers: TALER_BANK_DIRECTION_CANCELLED. However, it is not clear whether the cancellation happened on a outgoing or incoming transfer. Is this a bug? The wirewatch, for example, does not care about it but it may cause problems in the future.
TagsNo tags attached.

Activities

Christian Grothoff

2018-07-28 11:49

manager   ~0013154

I don't see how this matters. Cancelled is cancelled, regardless of direction.

Marcello Stanisci

2018-07-28 11:58

manager   ~0013158

Reported because "some partner banks" do distinguish on the base of the direction, and I wanted to bring attention to this.

Issue History

Date Modified Username Field Change
2018-07-20 13:56 Marcello Stanisci New Issue
2018-07-28 11:49 Christian Grothoff Note Added: 0013154
2018-07-28 11:57 Christian Grothoff Severity minor => tweak
2018-07-28 11:58 Marcello Stanisci Assigned To => Marcello Stanisci
2018-07-28 11:58 Marcello Stanisci Status new => resolved
2018-07-28 11:58 Marcello Stanisci Resolution open => no change required
2018-07-28 11:58 Marcello Stanisci Note Added: 0013158
2018-09-15 11:06 Christian Grothoff Fixed in Version => 0.6
2018-09-15 11:06 Christian Grothoff Target Version => 0.6