View Issue Details

IDProjectCategoryView StatusLast Update
0005330Talermechant backendpublic2018-06-12 08:59
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005330: Sporadic tests failures
DescriptionThe "lib" test cases showed those failures in a quite random way.

1:

May 22 09:10:02-146177 test-merchant-api-new-4401 DEBUG Running command `run-aggregator-11'
May 22 09:10:02-164984 taler-exchange-aggregator-4517 ERROR Assertion failed at taler-exchange-aggregator.c:639

2:

May 22 15:31:27-183633 test-merchant-api-7162 INFO Interpreter runs command 84/pay-abort-11(8)
May 22 15:31:27-200353 taler-merchant-httpd-7187 ERROR Unknown contract: NQRDS3SR (merchant_pub: S16KZC9V), no refund possible
May 22 15:31:27-200485 test-merchant-api-7162 INFO /pay completed with response code 200
May 22 15:31:27-200507 test-merchant-api-7162 INFO Interpreter runs command 85/pay-abort-refund-11(9)
May 22 15:31:27-200515 test-merchant-api-7162 ERROR Assertion failed at test_merchant_api.c:3694.
TagsNo tags attached.

Activities

Marcello Stanisci

2018-05-23 10:13

manager   ~0012952

Same failure on the abort CMD from the _new test case.

May 23 10:11:47-224319 test-merchant-api-new-11784 DEBUG Running command `pay-abort-11'
May 23 10:11:47-238310 taler-merchant-httpd-11810 ERROR Unknown contract: K2X3AQMB (merchant_pub: PQ436RXG), no refund possible
May 23 10:11:47-238435 test-merchant-api-new-11784 INFO /pay completed with response code 200
May 23 10:11:47-238459 test-merchant-api-new-11784 DEBUG Running command `pay-abort-refund-11'
May 23 10:11:47-238468 test-merchant-api-new-11784 ERROR Assertion failed at testing_api_cmd_pay.c:1481.
May 23 10:11:47-238472 test-merchant-api-new-11784 ERROR Failed at command `pay-abort-refund-11'
May 23 10:11:47-238479 test-merchant-api-new-11784 INFO Executing shutdown at `pay-abort-refund-11'

Marcello Stanisci

2018-05-23 10:49

manager   ~0012953

The pay-abort CMD causes fails at the twisted test case as well.

May 23 10:30:02-155331 test-merchant-api-twisted-13874 DEBUG Running command `pay-abort-4'
May 23 10:30:02-171794 test-merchant-api-twisted-13874 INFO /pay completed with response code 200
May 23 10:30:02-175343 test-merchant-api-twisted-13874 ERROR Unexpected response code 200 (0) to command pay-abort-4
May 23 10:30:02-175352 test-merchant-api-twisted-13874 ERROR Assertion failed at testing_api_cmd_pay.c:652.
May 23 10:30:02-175357 test-merchant-api-twisted-13874 ERROR Failed at command `pay-abort-4'
May 23 10:30:02-175374 test-merchant-api-twisted-13874 INFO Executing shutdown at `pay-abort-4'

Marcello Stanisci

2018-05-23 16:53

manager  

test_merchant_api.log (157,518 bytes)

Marcello Stanisci

2018-05-23 16:53

manager   ~0012955

Attached a log file.

Marcello Stanisci

2018-05-24 15:58

manager   ~0012956

Commit 041ad71 is very likely a fix for this issue.
Since this is not 100% verified yet, we keep this issue
in the 'feedback' state for "a while".

Marcello Stanisci

2018-05-24 18:58

manager  

test_merchant_api_twisted.log (9,841 bytes)

Marcello Stanisci

2018-05-24 18:59

manager   ~0012957

New failure from the twisted test, possibly
due to it being too slow; whole log file attached.

Marcello Stanisci

2018-05-25 10:56

manager   ~0012959

Resolving this and moving the twister issues in a dedicated file.

Issue History

Date Modified Username Field Change
2018-05-23 09:46 Marcello Stanisci New Issue
2018-05-23 09:46 Marcello Stanisci Status new => assigned
2018-05-23 09:46 Marcello Stanisci Assigned To => Marcello Stanisci
2018-05-23 10:13 Marcello Stanisci Note Added: 0012952
2018-05-23 10:49 Marcello Stanisci Note Added: 0012953
2018-05-23 16:53 Marcello Stanisci File Added: test_merchant_api.log
2018-05-23 16:53 Marcello Stanisci Note Added: 0012955
2018-05-24 15:58 Marcello Stanisci Status assigned => feedback
2018-05-24 15:58 Marcello Stanisci Note Added: 0012956
2018-05-24 18:58 Marcello Stanisci File Added: test_merchant_api_twisted.log
2018-05-24 18:59 Marcello Stanisci Status feedback => assigned
2018-05-24 18:59 Marcello Stanisci Note Added: 0012957
2018-05-25 10:56 Marcello Stanisci Note Added: 0012959
2018-05-25 10:56 Marcello Stanisci Status assigned => resolved
2018-05-25 10:56 Marcello Stanisci Resolution open => fixed
2018-06-12 08:59 Christian Grothoff Product Version => SVN HEAD
2018-06-12 08:59 Christian Grothoff Fixed in Version => 0.6