View Issue Details

IDProjectCategoryView StatusLast Update
0005190Talerdeployment and operationspublic2019-01-31 19:40
ReporterFlorian DoldAssigned To 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status confirmedResolutionopen 
Product VersionSVN HEAD 
Target Version0.7Fixed in Version 
Summary0005190: test, demo and buildbot do not restart on reboot despite cron job
DescriptionWe have a @reboot cron job, but for some reason it does not actually start these services. According to the syslog, these jobs *are* executed, but maybe the file system or other services are not ready yet?

It looks like buildbot does not have a @reboot cronjob at all.
Additional InformationDec 5 13:19:47 tripwire kernel: [ 19.645407] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
Dec 5 13:19:47 tripwire cron[897]: (CRON) INFO (Running @reboot jobs)

[...]

Dec 5 13:19:48 tripwire CRON[945]: (test-blue) CMD (source $HOME/activate; taler-deployment-restart)
Dec 5 13:19:48 tripwire CRON[947]: (demo-blue) CMD (source $HOME/activate; taler-deployment-restart)
Dec 5 13:19:48 tripwire CRON[948]: (test-green) CMD (source $HOME/activate; taler-deployment-restart)
Dec 5 13:19:48 tripwire CRON[944]: (demo-green) CMD (source $HOME/activate; taler-deployment-restart)
TagsNo tags attached.

Activities

Marcello Stanisci

2018-03-27 11:54

manager   ~0012901

Not sure how to test this! I guess someone should plug a monitor into
Tripwire and see what happens on reboot (?)

Issue History

Date Modified Username Field Change
2017-12-05 13:59 Florian Dold New Issue
2017-12-05 15:05 Christian Grothoff Severity minor => tweak
2017-12-05 15:05 Christian Grothoff Status new => confirmed
2017-12-05 15:05 Christian Grothoff Product Version => SVN HEAD
2017-12-14 15:51 Christian Grothoff Target Version => 0.6
2018-03-27 11:54 Marcello Stanisci Note Added: 0012901
2019-01-31 19:40 Christian Grothoff Target Version 0.6 => 0.7