View Issue Details

IDProjectCategoryView StatusLast Update
0005090Talerotherpublic2017-10-18 15:42
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.4Fixed in Version0.4 
Summary0005090: Unique error management
DescriptionBlog and donation need a unique point in the code where errors (especially the ones coming from the backend) are handled.
The code has too much repetition on this.
TagsNo tags attached.

Activities

Marcello Stanisci

2017-06-22 16:39

manager   ~0012263

Implemented in 0f25b1c5c1d8 in blog.

Marcello Stanisci

2017-06-22 16:41

manager   ~0012264

NOTE: the expect_parameter function is useless the way it's defined now, because
we never do 'return expect_parameter("x")' so we never benefit from it returning a error object upon errors.

A viable fix would be to raise a error upon errors, and have some catch-all error handler that returns the error object to the client.

Marcello Stanisci

2017-07-28 15:17

manager   ~0012371

donations fixed @ 3888fd6

Issue History

Date Modified Username Field Change
2017-06-21 15:02 Marcello Stanisci New Issue
2017-06-22 16:39 Marcello Stanisci Note Added: 0012263
2017-06-22 16:41 Marcello Stanisci Note Added: 0012264
2017-06-29 20:03 Christian Grothoff Assigned To => Marcello Stanisci
2017-06-29 20:03 Christian Grothoff Status new => assigned
2017-06-29 20:03 Christian Grothoff Product Version => SVN HEAD
2017-06-29 20:03 Christian Grothoff Target Version => 0.7
2017-07-28 15:17 Marcello Stanisci Status assigned => resolved
2017-07-28 15:17 Marcello Stanisci Resolution open => fixed
2017-07-28 15:17 Marcello Stanisci Note Added: 0012371
2017-07-29 14:25 Christian Grothoff Fixed in Version => 0.4
2017-07-29 14:25 Christian Grothoff Target Version 0.7 => 0.4
2017-10-18 15:42 Christian Grothoff Status resolved => closed