View Issue Details

IDProjectCategoryView StatusLast Update
0005067Talerdocumentationpublic2019-02-22 13:07
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PrioritynormalSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.7Fixed in Version 
Summary0005067: docs.taler.net/index.html should receive i18n and nicer styling
DescriptionMaybe a menu bar linking to bug tracker, mailinglist and Git, and definitively jinja2 i18n support for translations (also in menu bar).
TagsNo tags attached.

Activities

Marcello Stanisci

2018-09-24 13:45

manager   ~0013254

Links to mailing list, Git and Mantis do exist already. As of i18n, why would you translate a site with technical content? Devops are the target, so english should be enough, no?

Christian Grothoff

2018-09-24 13:51

manager   ~0013255

Last edited: 2018-09-24 13:51

View 2 revisions

There will be devops with limited knowledge of English, so indeed I do expect that some of the documentation will be translated over time.

Marcello Stanisci

2018-09-24 16:41

manager   ~0013256

Commit e4ad0228b1e984fff has the i18n implemented. Nicer styling is in progress..

Christian Grothoff

2019-02-20 18:40

manager   ~0013911

I'm actually largely fine with the *styling* as it is today. Just the i18n support is missing.

Marcello Stanisci

2019-02-21 14:23

manager   ~0013920

Commit: 63a1adf, contains a minimalistic languge bar to switch between languages (in pretty the same fashion of gnu.org). Now stricly speaking *this* issue is completed as the landing page got i18n'd, although it lacks the very translations. However, all the *other pages* lack i18n (manuals, API docs, everything..).

Marcello Stanisci

2019-02-21 17:22

manager   ~0013923

Reopening since the language switcher should be changed. In particular, it should appear as a drop-down menu like taler.net does. Among the other things, some blocks of text do not get translated (maybe the ones wrapped in {% trans %} ?).

Marcello Stanisci

2019-02-22 13:07

manager   ~0013944

Button language switcher added here: f03de12 (at docs-landing.git). If necessary, we'll file separate issues for the problematic "{% trans %}" blocks.

Issue History

Date Modified Username Field Change
2017-06-05 22:58 Christian Grothoff New Issue
2017-12-14 15:53 Christian Grothoff Status new => confirmed
2017-12-14 15:53 Christian Grothoff Target Version => 0.7
2018-09-24 11:08 Christian Grothoff Assigned To => Marcello Stanisci
2018-09-24 11:08 Christian Grothoff Status confirmed => assigned
2018-09-24 13:45 Marcello Stanisci Note Added: 0013254
2018-09-24 13:51 Christian Grothoff Note Added: 0013255
2018-09-24 13:51 Christian Grothoff Note Edited: 0013255 View Revisions
2018-09-24 16:41 Marcello Stanisci Note Added: 0013256
2019-02-20 17:51 Marcello Stanisci Status assigned => resolved
2019-02-20 17:51 Marcello Stanisci Resolution open => fixed
2019-02-20 18:37 Marcello Stanisci Status resolved => assigned
2019-02-20 18:40 Christian Grothoff Note Added: 0013911
2019-02-21 14:23 Marcello Stanisci Status assigned => resolved
2019-02-21 14:23 Marcello Stanisci Note Added: 0013920
2019-02-21 17:22 Marcello Stanisci Status resolved => assigned
2019-02-21 17:22 Marcello Stanisci Note Added: 0013923
2019-02-22 13:07 Marcello Stanisci Status assigned => resolved
2019-02-22 13:07 Marcello Stanisci Note Added: 0013944