View Issue Details

IDProjectCategoryView StatusLast Update
0005033Talerbank (demonstrator)public2017-06-06 14:18
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0005033: "invalid parameters" on withdraw
DescriptionWhen I try to withdraw from the bank (local setup on my system @ home), I get "invalid parameters" on the /pin/question-page. The error message is horrible as it doesn't say what parameters are invalid (and does not mention a globally unique error code either). Can't say if the bank or the wallet is to blame either. The information provided by the exchange seems correct (uses the correct bank account number and its correct URL at localhost:8081).
Additional InformationRequest URI is:

http://localhost:8888/pin/question?wire_details=%7B%22test%22%3A%7B%22type%22%3A%22test%22%2C%22account_number%22%3A2%2C%22bank_uri%22%3A%22http%3A%2F%2Flocalhost%3A8888%2F%22%7D%7D&exchange=http%3A%2F%2Flocalhost%3A8081%2F&reserve_pub=6K0EEZNZS8R04NKZXNT101MCZE9RF8R4Z2RREGDA5N7JYM187ZSG&amount_value=1&amount_fraction=0&amount_currency=KUDOS
TagsNo tags attached.

Relationships

child of 0003464 closedChristian Grothoff Need a tool to import wire transfers from the bank 

Activities

Marcello Stanisci

2017-05-29 10:56

manager   ~0012179

More details should be returned about the failure, as of 9430850.

Unfortunately, I couldn't reproduce this error locally; that suggests you are
running some outdated code - some leftover from ancient installs.

Ah, check that the wallet is updated too.

Marcello Stanisci

2017-05-29 13:36

manager   ~0012181

The parameter 'wire_details' is bad, as it clearly lacks a field named "name".

This suggests that the wallet is old.

Christian Grothoff

2017-05-29 13:44

manager   ~0012183

Hmm. Is 'name' mandatory? Because:
1) the exchange doesn't check for it;
2) the wallet version I have clearly doesn't complain if it is missing.

Should it be mandatory?

Florian Dold

2017-05-29 14:48

manager   ~0012184

Last edited: 2017-05-29 14:49

View 2 revisions

The wallet treats wire details _mostly_ as an opaque object, it just removes methods that are not in the wt_types given by the bank and deletes the fees/salt/sig properties, because otherwise the URL is too long and the fees are not used by the bank anyway.

Otherwise it doesn't do any parsing, and I'm not sure it should.

Christian Grothoff

2017-05-29 14:56

manager   ~0012185

Ok, so let's make 'name' optional. No need for excessive checks, and while 'name' clearly often makes sense, I don't see why we really need it.

Marcello Stanisci

2017-05-29 15:03

manager   ~0012186

It's optional starting from b3486f1. Please close this whenever you'll correctly withdraw.

Christian Grothoff

2017-05-29 18:27

manager   ~0012187

Ok, this part works now (but see my e-mail)...

Issue History

Date Modified Username Field Change
2017-05-24 23:53 Christian Grothoff New Issue
2017-05-24 23:53 Christian Grothoff Status new => assigned
2017-05-24 23:53 Christian Grothoff Assigned To => Marcello Stanisci
2017-05-24 23:54 Christian Grothoff Relationship added child of 0003464
2017-05-29 10:56 Marcello Stanisci Note Added: 0012179
2017-05-29 13:36 Marcello Stanisci Note Added: 0012181
2017-05-29 13:44 Christian Grothoff Note Added: 0012183
2017-05-29 14:48 Florian Dold Note Added: 0012184
2017-05-29 14:49 Florian Dold Note Edited: 0012184 View Revisions
2017-05-29 14:56 Christian Grothoff Note Added: 0012185
2017-05-29 15:03 Marcello Stanisci Note Added: 0012186
2017-05-29 18:27 Christian Grothoff Status assigned => resolved
2017-05-29 18:27 Christian Grothoff Resolution open => fixed
2017-05-29 18:27 Christian Grothoff Fixed in Version => 0.3
2017-05-29 18:27 Christian Grothoff Note Added: 0012187
2017-06-06 14:18 Christian Grothoff Status resolved => closed