View Issue Details

IDProjectCategoryView StatusLast Update
0005021Talerbank (demonstrator)public2019-03-15 05:41
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PrioritynormalSeveritytextReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.3 
Target Version0.6Fixed in Version0.6 
Summary0005021: python logic should be documented in doxygen-compatible style
DescriptionSee the 2nd style "##" under:

http://www.stack.nl/~dimitri/doxygen/manual/docblocks.html#pythonblocks

Basically, each module, class function, argument and return value should be documented. (Not only for the bank, but -especially- the Python frontends).
TagsNo tags attached.

Activities

Marcello Stanisci

2019-03-06 15:28

manager   ~0014151

The link in the description is not working anymore. Use the following: http://www.doxygen.nl/manual/docblocks.html#pythonblocks

Marcello Stanisci

2019-03-06 18:00

manager   ~0014154

All the pythons now have a Doxygen file, and the bank has some little amount of doxygen-commented code. However, a quick-and-dirty doxygen run at the bank didn't produce any useful output. Needs investigation.

Marcello Stanisci

2019-03-06 18:06

manager   ~0014157

Fixed here: b8761e7..eec9e0e

Marcello Stanisci

2019-03-06 18:07

manager   ~0014158

We keep this open until all the code has been commented.

Marcello Stanisci

2019-03-12 18:06

manager   ~0014190

All the main *.py from the bank and frontends got commented. I'm leaving this open since also the *.in "manage scripts" should be Doxygen-commented.

Marcello Stanisci

2019-03-13 15:29

manager   ~0014192

Last edited: 2019-03-13 15:30

View 2 revisions

All the *.in got now commented in all the codebases. The commenting might not be perfect everywhere, but all the infrastructure is set up, and all the main files got commented, so this issue can be closed in my opinion.

The fix:
After mapping in-files to the Python engine (MAPPING_EXTENSION option),
the real unblocker was to set EXTRACT_ALL = YES, as standalone scripts do not
usually have classes defined (therefore Doxygen ignores such files, by default).

Issue History

Date Modified Username Field Change
2017-05-22 14:32 Christian Grothoff New Issue
2017-05-22 14:32 Christian Grothoff Status new => assigned
2017-05-22 14:32 Christian Grothoff Assigned To => Marcello Stanisci
2017-12-14 15:53 Christian Grothoff Target Version => 0.7
2019-03-06 15:28 Marcello Stanisci Note Added: 0014151
2019-03-06 18:00 Marcello Stanisci Note Added: 0014154
2019-03-06 18:06 Marcello Stanisci Note Added: 0014157
2019-03-06 18:07 Marcello Stanisci Note Added: 0014158
2019-03-12 18:06 Marcello Stanisci Note Added: 0014190
2019-03-13 15:29 Marcello Stanisci Note Added: 0014192
2019-03-13 15:30 Marcello Stanisci Status assigned => resolved
2019-03-13 15:30 Marcello Stanisci Resolution open => fixed
2019-03-13 15:30 Marcello Stanisci Note Edited: 0014192 View Revisions
2019-03-15 05:41 Christian Grothoff Fixed in Version => 0.6
2019-03-15 05:41 Christian Grothoff Target Version 0.7 => 0.6