View Issue Details

IDProjectCategoryView StatusLast Update
0004999Talerotherpublic2017-06-06 14:18
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0004999: mitm loops on /keys
Descriptionwhenever the merchant tries to get /keys from an exchange proxied by the
MITM software layer, it keeps fetching /keys infinitely.
Steps To Reproduceexecute mitm.py located at src/mitm under the merchant repository,
make it point to a running exchange - by exporting the env variable
TALER_EXCHANGE_URL set to a running exchange's URL, and set the merchant
backend to use the mitm as the exchange.
TagsNo tags attached.

Activities

Marcello Stanisci

2017-04-28 11:53

manager   ~0012077

update about reproducing the issue: the mitm can now be executed by calling
the taler-merchant-mitm tool, passing the exchange's url to it.

See taler-merchant-mitm --help

Marcello Stanisci

2017-04-28 18:57

manager   ~0012079

This *used* to happen because the mitm did not send back the "Expiration"
HTTP header to the merchant, so /keys' response appeared as expired, and the
download got retried.

This has been fixed by returning all the HTTP headers verbatim to the merchant.

The issue now is that the /keys' response gets "cut" at some point, so the JSON
is invalid.

Marcello Stanisci

2017-05-02 09:02

manager   ~0012091

ee0fb92. Content-Length header used to "cut" the response making it invalid.

Issue History

Date Modified Username Field Change
2017-04-27 16:09 Marcello Stanisci New Issue
2017-04-27 16:10 Marcello Stanisci Assigned To => Marcello Stanisci
2017-04-27 16:10 Marcello Stanisci Status new => assigned
2017-04-28 11:53 Marcello Stanisci Note Added: 0012077
2017-04-28 18:57 Marcello Stanisci Note Added: 0012079
2017-05-02 09:02 Marcello Stanisci Status assigned => resolved
2017-05-02 09:02 Marcello Stanisci Resolution open => fixed
2017-05-02 09:02 Marcello Stanisci Note Added: 0012091
2017-05-03 02:16 Christian Grothoff Fixed in Version => 0.3
2017-05-03 02:17 Christian Grothoff Target Version => 0.3
2017-05-05 00:02 Christian Grothoff Product Version => SVN HEAD
2017-06-06 14:18 Christian Grothoff Status resolved => closed