View Issue Details

IDProjectCategoryView StatusLast Update
0004912Talermechant backendpublic2017-06-06 14:18
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0004912: order_id's role in tracking activity
Descriptionorder_id needs to be placed "somewhere" in the db, so that for the MFE is
easy to query it and get results.

Right now, order_id is NOT in the merchant_transactions table, so the /history
handler should (?) do some more db queries in order to return meaningful results.

Figure out what is the best place to put order_id..
TagsNo tags attached.

Activities

Marcello Stanisci

2017-02-23 18:13

manager   ~0011841

we keep two tables: one that maps order_id to proposal data and relative timestamp,
and one that maps proposal data hashes to payment details.

So in case of /history we retrieve order ids and proposal data from the first table,
then hash proposal data and get other relevant details from the second table.

The reason to split those two tables is that the first one offers a view more frontend-friendly:
we keep there only data understood by frontends. OTOH, the second one offers a view which is
closer to what a merchant backend and an exchange are interested in in terms of payments.

Marcello Stanisci

2017-02-23 21:20

manager   ~0011842

From 2fafeda, order_id now belongs to 'merchant_proposal_data' table.

Issue History

Date Modified Username Field Change
2017-02-22 17:03 Marcello Stanisci New Issue
2017-02-22 17:03 Marcello Stanisci Status new => assigned
2017-02-22 17:03 Marcello Stanisci Assigned To => Marcello Stanisci
2017-02-23 18:13 Marcello Stanisci Note Added: 0011841
2017-02-23 21:20 Marcello Stanisci Status assigned => resolved
2017-02-23 21:20 Marcello Stanisci Resolution open => fixed
2017-02-23 21:20 Marcello Stanisci Note Added: 0011842
2017-04-02 00:47 Christian Grothoff Product Version => SVN HEAD
2017-04-02 00:47 Christian Grothoff Fixed in Version => 0.3
2017-04-02 00:47 Christian Grothoff Target Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed