View Issue Details

IDProjectCategoryView StatusLast Update
0004876Talerdeployment and operationspublic2017-06-06 14:18
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0004876: setup auditor in deployment
DescriptionThis is basically about generating an auditor key, and calling the command taler-auditor-sign on the exchange's key material to sign it, and to give the command's output to the exchange so it can serve it. Man pages exist...
TagsNo tags attached.

Activities

Florian Dold

2017-02-13 09:58

manager   ~0011729

There's one more thing to it: We should have a website that triggers the wallet's mechanism to add an auditor.

Marcello Stanisci

2017-02-13 16:41

manager   ~0011737

The auditor signs denomkeys in the format output by 'taler-exchange-keyup -o OUTPUTFILE'.

However, the command 'taler-exchange-keyup -o OUTPUTFILE' just creates a *empty* file named OUTPUTFILE.

Christian, can you reproduce this?

Christian Grothoff

2017-02-13 19:05

manager   ~0011738

Yes. But the issue is _how_ you use the tool. It _only_ works for keys that are being generated by keyup. So if the existing keys already suffice and no new keys are being generated, you get an empty file. So try this for either a "fresh" installation and/or after removing the denomination keys manually.

Later, an empty file should be considered as "nothing to be done", while non-empty files in the deployment trigger the auditor's signing process.

Marcello Stanisci

2017-02-14 11:44

manager   ~0011746

Yes, resetting the keyset made it work, BUT: although the output file
is correctly written, taler-exchange-keyup keeps returning error messages
about the write failing on the output file.

The problem is that fwrite returns 1, and the 'if' statement expects it to
return 256. The weird thing is that fwrite should return 256 when its third
parameter is set to 1 (at least 'man fwrite' says that) - which is our case.

Christian Grothoff

2017-02-14 13:25

manager   ~0011747

Fixed the return value check in 6e46853..5b3f346

Marcello Stanisci

2017-02-14 13:50

manager   ~0011748

Ok, it works. But, aren't we violating what the manual page says
about fwrite's return value? It should return 256 there...

Christian Grothoff

2017-02-14 14:11

manager   ~0011749

Nope, fwrite returns number of records, and we gave it 1 record of 256 bytes, not 256 records of 1 byte.

Marcello Stanisci

2017-02-14 15:32

manager   ~0011750

Fixed in d5724e6 (deployment.git).

The utility taler-deployment-start (called to bring up a "test" or "demo" environment) takes care of generating the
key material to feed the auditor and to get it signed by
 taler-auditor-sign.

Issue History

Date Modified Username Field Change
2017-02-01 13:54 Christian Grothoff New Issue
2017-02-01 13:54 Christian Grothoff Status new => assigned
2017-02-01 13:54 Christian Grothoff Assigned To => Marcello Stanisci
2017-02-10 18:02 Marcello Stanisci Priority normal => high
2017-02-13 09:58 Florian Dold Note Added: 0011729
2017-02-13 16:41 Marcello Stanisci Note Added: 0011737
2017-02-13 19:05 Christian Grothoff Note Added: 0011738
2017-02-14 11:44 Marcello Stanisci Note Added: 0011746
2017-02-14 13:25 Christian Grothoff Note Added: 0011747
2017-02-14 13:50 Marcello Stanisci Note Added: 0011748
2017-02-14 14:11 Christian Grothoff Note Added: 0011749
2017-02-14 15:32 Marcello Stanisci Status assigned => resolved
2017-02-14 15:32 Marcello Stanisci Resolution open => fixed
2017-02-14 15:32 Marcello Stanisci Note Added: 0011750
2017-05-03 02:16 Christian Grothoff Fixed in Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed