View Issue Details

IDProjectCategoryView StatusLast Update
0004804TalerWeb site(s)public2017-06-06 14:18
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.3Fixed in Version0.3 
Summary0004804: lcov borked
DescriptionThis may be related to the buildbot being down. But the lcov site is both:
1) very outdated (lacks a recent build)
2) clearly incorrect, it seems the test suite was not actually fully run
3) misses entirely for the merchant backend
TagsNo tags attached.

Relationships

related to 0004627 closedMarcello Stanisci buildbot down 
related to 0004780 closedMarcello Stanisci Buildbot unwordy 

Activities

Marcello Stanisci

2016-12-19 18:20

manager   ~0011594

b20b2f9 of deployment now triggers lcov thanks to the --coverage flag
from update_{merchant,exchange}.sh scripts; so we got rid of the old
coverage.sh.

The actual triggering from buildbot is missing.

Marcello Stanisci

2016-12-19 23:16

manager   ~0011596

The charts still look weird.

Marcello Stanisci

2016-12-20 11:20

manager   ~0011598

They looked weird due to testcases failures. They look now "poor", as the code
grew up, and it is not quite 100% tested.

Triggering from buildbot still missing.

Marcello Stanisci

2016-12-20 11:34

manager   ~0011599

In order to manually test the coverage, run
  
  # From a standalone deployment:

  $ . activate
  $ taler-deployment-build --coverage

Marcello Stanisci

2017-02-14 21:11

manager   ~0011760

Correctly triggered by buildbot, just tested.

Issue History

Date Modified Username Field Change
2016-11-18 23:21 Christian Grothoff New Issue
2016-11-18 23:21 Christian Grothoff Status new => assigned
2016-11-18 23:21 Christian Grothoff Assigned To => Marcello Stanisci
2016-11-18 23:21 Christian Grothoff Relationship added related to 0004627
2016-12-07 14:25 Marcello Stanisci Priority normal => high
2016-12-19 18:20 Marcello Stanisci Note Added: 0011594
2016-12-19 23:16 Marcello Stanisci Note Added: 0011596
2016-12-20 11:20 Marcello Stanisci Note Added: 0011598
2016-12-20 11:34 Marcello Stanisci Note Added: 0011599
2016-12-22 17:05 Marcello Stanisci Relationship added related to 0004780
2017-01-27 11:19 Marcello Stanisci Priority high => urgent
2017-02-10 18:05 Marcello Stanisci Priority urgent => high
2017-02-14 21:11 Marcello Stanisci Status assigned => resolved
2017-02-14 21:11 Marcello Stanisci Resolution open => fixed
2017-02-14 21:11 Marcello Stanisci Note Added: 0011760
2017-05-03 02:16 Christian Grothoff Fixed in Version => 0.3
2017-06-06 14:18 Christian Grothoff Status resolved => closed