View Issue Details

IDProjectCategoryView StatusLast Update
0004771Talerwallet (WebExtensions)public2018-04-15 20:33
ReporterMarcello StanisciAssigned ToFlorian Dold 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.5Fixed in Version0.5 
Summary0004771: Error code swallowed.
DescriptionThe merchant frontend says nothing about the following error. Indagate where the error code
got swallowed: could be backend/frontend/or even exchange.

Nov 09 16:02:57-006923 taler-exchange-httpd-5943 ERROR Wire specifies bank URI https://bank.test.taler.net/, but this exchange only supports http://localbank/
Nov 09 16:02:57-007139 taler-merchant-httpd-5946 WARNING Deposit operation failed with HTTP code 404
Steps To ReproducePick a Taler installation, change fsf.json so that it contains a "bank_uri" field that differs from exchange's and try to buy a blog article.

Then see the error logged in the console.
TagsNo tags attached.

Activities

Marcello Stanisci

2017-07-28 10:10

manager   ~0012369

The frontend just responds to /pay by echoing what the exchange says - just reproduced. Since the communication is Wallet<->Frontend, it is wallet responsibility to inform the user via its UI.

Note that the error *is* handled, but it's just logged in the console.. I'm going to change category and assigned person.

Christian Grothoff

2018-01-30 08:30

manager   ~0012837

Should this be fixed for 0.5?

Florian Dold

2018-01-30 12:34

manager   ~0012840

This was already "silently" fixed, the merchant frontends now always have nice, informative error pages when something with a backend request goes wrong.

Issue History

Date Modified Username Field Change
2016-11-09 17:59 Marcello Stanisci New Issue
2016-11-09 17:59 Marcello Stanisci Status new => assigned
2016-11-09 17:59 Marcello Stanisci Assigned To => Marcello Stanisci
2016-11-15 15:39 root Product Version => SVN HEAD
2016-11-15 15:39 root Target Version => 0.3
2017-03-06 00:26 Christian Grothoff Severity minor => major
2017-05-02 14:44 Christian Grothoff Target Version 0.3 => 0.7
2017-07-28 10:10 Marcello Stanisci Note Added: 0012369
2017-07-28 10:12 Marcello Stanisci Assigned To Marcello Stanisci => Florian Dold
2017-07-28 10:12 Marcello Stanisci Category mechant backend => wallet (WebExtensions)
2017-07-28 10:12 Marcello Stanisci Steps to Reproduce Updated View Revisions
2018-01-30 08:30 Christian Grothoff Note Added: 0012837
2018-01-30 12:34 Florian Dold Status assigned => resolved
2018-01-30 12:34 Florian Dold Resolution open => fixed
2018-01-30 12:34 Florian Dold Note Added: 0012840
2018-01-30 14:19 Florian Dold Target Version 0.7 => 0.5
2018-01-31 11:59 Christian Grothoff Fixed in Version => 0.5
2018-04-15 20:33 Christian Grothoff Status resolved => closed