View Issue Details

IDProjectCategoryView StatusLast Update
0004758Talerbank (demonstrator)public2016-11-20 03:26
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.2Fixed in Version0.2 
Summary0004758: unix socket not created by python script
DescriptionWhen the bank is launched by 'taler-bank-manage serve-uwsgi', the expected
unix domain sockets in /tmp are not created. If instead the bank is launched with:

uwsgi --emperor <PFX>/share/taler-bank/vassals-unix/

then the sockets are correctly created.
TagsNo tags attached.

Activities

Marcello Stanisci

2016-11-03 14:45

manager   ~0011412

Adding the Python guru :-)

Florian Dold

2016-11-03 16:23

manager   ~0011413

Why do we even have sockets in the global '/tmp'? I don't understand the problem well enough to give any advice.

Is there a reason we need to use uwsgi's emperor/vassal mechanism? Can't we just have two uwsgi services, one for the bank's admin interface and one for the frontent, both run separately by gnunet-arm?

Marcello Stanisci

2016-11-03 17:30

manager   ~0011414

We use the emperor thing because is the uwsgi way of running multi app/instances
services, and we launch both apps with one command. It is also handier to launch
the bank manually for quickly looking at the output.

Basically, any vassal gets configured in a .ini file, and in those files you
indicate where on the filesystem you want your sockets created.
Sockets in /tmp are just a default value we have for vassals (as we don't want
to save on git tripwire's specific paths like ~/sockets/). It can be changed in
<PFX>/share/taler-bank/vassals-unix/*.ini.

The good side of your solution is that we don't move away part of the configuration
from ~/.config/taler.conf. I'm not strictly against.

Florian Dold

2016-11-03 19:35

manager   ~0011417

Hmm, I wouldn't be completely opposed to using uwsgi's vassals/emperor, but it seems like it's more of a pain than a gain.

So unless it simplifies things a lot, we should just have two separate services!

Marcello Stanisci

2016-11-04 13:47

manager   ~0011425

Fixed in 174dab7. Actually preferred changing the implementation to your
suggestion instead of indagating why the Emperor does not create sockets.
(test) config file in deployment also updated.

Issue History

Date Modified Username Field Change
2016-11-03 13:07 Marcello Stanisci New Issue
2016-11-03 13:07 Marcello Stanisci Status new => assigned
2016-11-03 13:07 Marcello Stanisci Assigned To => Marcello Stanisci
2016-11-03 13:37 Marcello Stanisci Additional Information Updated View Revisions
2016-11-03 13:38 Marcello Stanisci Priority normal => high
2016-11-03 14:45 Marcello Stanisci Note Added: 0011412
2016-11-03 16:23 Florian Dold Note Added: 0011413
2016-11-03 17:30 Marcello Stanisci Note Added: 0011414
2016-11-03 19:35 Florian Dold Note Added: 0011417
2016-11-04 13:47 Marcello Stanisci Note Added: 0011425
2016-11-04 13:47 Marcello Stanisci Status assigned => resolved
2016-11-04 13:47 Marcello Stanisci Resolution open => fixed
2016-11-15 15:41 root Product Version => SVN HEAD
2016-11-15 15:41 root Fixed in Version => 0.2
2016-11-15 15:41 root Target Version => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed