View Issue Details

IDProjectCategoryView StatusLast Update
0004749Talermerchant backend API (HTTP specification)public2016-11-20 03:26
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityhighSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.1 
Target Version0.2Fixed in Version0.2 
Summary0004749: receiver -> instance
DescriptionIn the API for the backend, we use the term "receiver" to specify which bank account/instance/merchant public key/iban should be used by the backend for a given request. Inside the backend, the code uses the term "instance".

I prefer "instance" over "receiver". In any case, we need to standardize to one of the two terms, in code, protocol and documentation. This bug also affects the various frontends if we change "receiver" to "instance".
TagsNo tags attached.

Relationships

parent of 0004750 closedFlorian Dold New names for contract's fields 

Activities

Marcello Stanisci

2016-10-22 19:28

manager   ~0011377

Fixed in merchant BE+FE, and API doc. Testcase passes but could not try a complete purchase since the wallet needs to be updated to accpet new names.
(See related bug).

Marcello Stanisci

2016-10-22 19:30

manager   ~0011378

BTW: "receiver" was really a bad choice!

Marcello Stanisci

2016-11-07 09:54

manager   ~0011440

Waiting for 0004754 for testing.

Marcello Stanisci

2016-11-07 16:50

manager   ~0011443

Waiting for 0004762

Marcello Stanisci

2016-11-09 18:05

manager   ~0011466

Manually tested.

Issue History

Date Modified Username Field Change
2016-10-22 17:04 Christian Grothoff New Issue
2016-10-22 17:04 Christian Grothoff Status new => assigned
2016-10-22 17:04 Christian Grothoff Assigned To => Marcello Stanisci
2016-10-22 19:28 Marcello Stanisci Note Added: 0011377
2016-10-22 19:30 Marcello Stanisci Note Added: 0011378
2016-10-24 17:28 Marcello Stanisci Relationship added parent of 0004750
2016-11-07 09:53 Marcello Stanisci Priority normal => high
2016-11-07 09:54 Marcello Stanisci Note Added: 0011440
2016-11-07 16:50 Marcello Stanisci Note Added: 0011443
2016-11-09 18:05 Marcello Stanisci Status assigned => resolved
2016-11-09 18:05 Marcello Stanisci Resolution open => fixed
2016-11-09 18:05 Marcello Stanisci Note Added: 0011466
2016-11-15 16:03 Christian Grothoff Fixed in Version => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed