View Issue Details

IDProjectCategoryView StatusLast Update
0004696Talerwallet (browser-based)public2016-10-11 17:28
ReporterChristian GrothoffAssigned ToFlorian Dold 
PriorityhighSeveritytextReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionSVN HEAD 
Target Version0.1Fixed in Version0.1 
Summary0004696: should improve texts shown in history
DescriptionThe current texts do not show the most important information, and use too complex language (yes, I want it dead simple). Suggestions below; ALL CAPS are to be substituted.

For payments:

Paid X.YY CURRENCY for PRODUCT-SUMMARY.

Make "Paid" a link to view the contract (omit while such a page doesn't yet exist), and "product summary" a link to the fulfillment page. Render X.YY currency in red (loss).

For withdrawals:

Withdrew X.YY CURRENCY from EXCHANGE (WTID).

Make "Withdrew" a link to a page with the fee structure if the operation (omit while such a page doesn't yet exist).


I've not yet been able to see what you show for active transactions ;-). But we could use the same formulations with just:

Withdrawing
Paying


Later, things like refresh and refund will require some careful wording as well.

TagsNo tags attached.

Relationships

related to 0004207 closedFlorian Dold wallet contains incomprehensible messages 

Activities

Florian Dold

2016-10-03 17:40

manager   ~0011235

I'm not completely happy with those.

1. I think that e.g. the link to the contract should be explicit, and not liked to "Payed", which is not easily discoverable.

2. In general, it's confusing right now when an amount includes fees and when not. Should the amount for the "withdrawing" message be what is taken out of the reserve, or what will end up in the users wallet? Can we make this distinction clear somehow?

Florian Dold

2016-10-10 03:16

manager   ~0011279

Fixed as far as possible in ce4d9c4.

We can't really display a product summary, since the contract doesn't have this information.

Issue History

Date Modified Username Field Change
2016-09-29 10:54 Christian Grothoff New Issue
2016-09-29 10:54 Christian Grothoff Status new => assigned
2016-09-29 10:54 Christian Grothoff Assigned To => Florian Dold
2016-09-29 10:57 Christian Grothoff Relationship added related to 0004207
2016-10-03 17:40 Florian Dold Note Added: 0011235
2016-10-10 03:16 Florian Dold Note Added: 0011279
2016-10-10 03:16 Florian Dold Status assigned => resolved
2016-10-10 03:16 Florian Dold Resolution open => fixed
2016-10-11 17:24 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed