View Issue Details

IDProjectCategoryView StatusLast Update
0004689Talermerchant backend API (C)public2016-10-11 17:28
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004689: Need API to get history
DescriptionThis API is mostly needed to use the /track API, because there is no handy way for a frontend now to get a list of transaction IDs to feed to /track/transaction. So this API, presumably called "/history", or "/records" should return a list of all the transactions (ID, contract's hash, etc.) up to 'some point' in the past.
TagsNo tags attached.

Activities

Marcello Stanisci

2016-10-03 15:33

manager   ~0011233

todo: iterate over returned tuples

Marcello Stanisci

2016-10-04 17:50

manager   ~0011238

need testcase

Marcello Stanisci

2016-10-04 22:56

manager   ~0011253

testcase loops ..

Marcello Stanisci

2016-10-05 23:34

manager   ~0011263

Fixed in 61cc8f9. The testcase takes long to terminate because taler-merchant-httpd process does not die immediately, though.

Issue History

Date Modified Username Field Change
2016-09-27 14:04 Marcello Stanisci New Issue
2016-09-27 14:04 Marcello Stanisci Status new => assigned
2016-09-27 14:04 Marcello Stanisci Assigned To => Marcello Stanisci
2016-09-27 22:21 Christian Grothoff Severity minor => feature
2016-09-27 22:21 Christian Grothoff Product Version => 0.0
2016-09-27 22:27 Christian Grothoff Target Version 0.1 => 0.2
2016-10-03 15:33 Marcello Stanisci Note Added: 0011233
2016-10-04 17:50 Marcello Stanisci Note Added: 0011238
2016-10-04 22:56 Marcello Stanisci Note Added: 0011253
2016-10-05 23:34 Marcello Stanisci Note Added: 0011263
2016-10-05 23:34 Marcello Stanisci Status assigned => resolved
2016-10-05 23:34 Marcello Stanisci Resolution open => fixed
2016-10-07 00:28 Christian Grothoff Fixed in Version => 0.1
2016-10-07 00:28 Christian Grothoff Target Version 0.2 => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed