View Issue Details

IDProjectCategoryView StatusLast Update
0004657Talermechant backendpublic2018-01-30 08:36
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version0.0 
Target Version0.2Fixed in Version0.2 
Summary0004657: /track/* bad logs
DescriptionThe merchant BE shows a few bad looking logs, like the following:

1.
Sep 14 14:22:01-916149 taler-merchant-httpd-21475 ERROR Assertion failed at taler-merchant-httpd_track-transaction.c:721

2.
Sep 14 10:51:36-956523 taler-merchant-httpd-21475 ERROR Assertion failed at plugin_merchantdb_postgres.c:470.
Sep 14 10:51:36-956556 taler-merchant-httpd-21475 ERROR Database failure: ERROR: duplicate key value violates unique constraint "merchant_transfers_pkey"
DETAIL: Key (transaction_id, coin_pub)=(1017845521133909, \x670ad419769ae8c1a78abac318e6004a93ce55aef303928a26940dad4910b28a) already exists.

Sep 14 10:51:36-956573 taler-merchant-httpd-21475 ERROR Failed to persist coin to wire transfer mapping in DB

1. happens on /track/transaction (always), 2. on /track/transfer (not always).
Steps To ReproduceGo to shop.test.taler.net/track and try to track your transfers/transactions
TagsNo tags attached.

Activities

Marcello Stanisci

2016-09-15 10:14

manager   ~0011117

Gotten the following as well:

3. 'Failed to store coin-to-transfer mapping in DB'

Marcello Stanisci

2016-09-16 15:41

manager   ~0011120

Not able to manually reproduce it after erasing the DB. Some bogus data may have corrupted things. Try on test cases ..

Marcello Stanisci

2016-10-11 17:21

manager   ~0011295

Could not reproduce

Marcello Stanisci

2016-10-11 22:01

manager   ~0011310

Again, but still not reproduced (affects 52e82c8e9)

Oct 11 21:37:47-300742 taler-merchant-httpd-826 ERROR Assertion failed at plugin_merchantdb_postgres.c:486.
Oct 11 21:37:47-300784 taler-merchant-httpd-826 ERROR Database failure: ERROR: duplicate key value violates unique constraint "merchant
_transfers_pkey"
DETAIL: Key (transaction_id, coin_pub)=(678634139771024, \x8ad1369621c472ae02c3aeb7f230b1b6d375a3d6e0e8f13b9982246147e3f5a5) already ex
ists.

Christian Grothoff

2016-10-14 15:18

manager   ~0011324

Not sure if fixed, Marcello will monitor to see if this is still an issue.

Christian Grothoff

2016-10-27 23:00

manager   ~0011395

Marcello ponders whether d50060c..8814b79 might have fixed this.

Marcello Stanisci

2016-11-30 15:03

manager   ~0011556

Reappeared.

Nov 30 14:57:12-705657 taler-merchant-httpd-13121 ERROR Failed to store coin-to-transfer mapping in DB
Nov 30 14:57:12-705665 taler-merchant-httpd-13121 DEBUG Executing prepared SQL statement `insert_transfer'
Nov 30 14:57:12-705914 taler-merchant-httpd-13121 ERROR Assertion failed at plugin_merchantdb_postgres.c:516.
Nov 30 14:57:12-705935 taler-merchant-httpd-13121 ERROR Database failure: ERROR: duplicate key value violates unique constraint "merchant_transfers_pkey"
DETAIL: Key (transaction_id, coin_pub)=(509850176400709, \x183c8c8fd70a2d7ddd7ae127cd70325837c38a09fce3d9923732d8eb56a3ad01) already exists.

Nov 30 14:57:12-705944 taler-merchant-httpd-13121 ERROR Failed to store coin-to-transfer mapping in DB
Nov 30 14:57:12-705990 taler-merchant-httpd-13121 INFO Handling request for URL `/track/transaction'

Marcello Stanisci

2016-11-30 15:04

manager   ~0011557

It doesn't seem to crash things though, so not (?) demo-killer.

Marcello Stanisci

2016-12-08 17:25

manager   ~0011584

Likely to be gone with 1a273fd.

Christian Grothoff

2018-01-30 08:36

manager   ~0012838

Please file new report if this comes back.

Issue History

Date Modified Username Field Change
2016-09-14 15:38 Marcello Stanisci New Issue
2016-09-14 15:38 Marcello Stanisci Status new => assigned
2016-09-14 15:38 Marcello Stanisci Assigned To => Marcello Stanisci
2016-09-14 15:38 Marcello Stanisci Priority normal => high
2016-09-15 10:14 Marcello Stanisci Note Added: 0011117
2016-09-16 15:41 Marcello Stanisci Note Added: 0011120
2016-09-22 15:19 Marcello Stanisci Reproducibility have not tried => unable to reproduce
2016-09-26 13:55 Christian Grothoff Product Version => 0.0
2016-09-26 13:55 Christian Grothoff Target Version => 0.1
2016-09-27 22:29 Christian Grothoff Target Version 0.1 => 0.2
2016-10-11 17:21 Marcello Stanisci Note Added: 0011295
2016-10-11 17:21 Marcello Stanisci Assigned To Marcello Stanisci =>
2016-10-11 17:21 Marcello Stanisci Status assigned => feedback
2016-10-11 17:22 Marcello Stanisci Priority high => low
2016-10-11 22:01 Marcello Stanisci Note Added: 0011310
2016-10-11 22:01 Marcello Stanisci Status feedback => new
2016-10-11 22:01 Marcello Stanisci Priority low => normal
2016-10-11 22:01 Marcello Stanisci Status new => acknowledged
2016-10-14 15:18 Christian Grothoff Note Added: 0011324
2016-10-14 15:18 Christian Grothoff Assigned To => Marcello Stanisci
2016-10-14 15:18 Christian Grothoff Status acknowledged => feedback
2016-10-27 23:00 Christian Grothoff Note Added: 0011395
2016-11-19 12:56 Christian Grothoff Status feedback => resolved
2016-11-19 12:56 Christian Grothoff Resolution open => fixed
2016-11-19 12:56 Christian Grothoff Fixed in Version => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed
2016-11-30 15:02 Marcello Stanisci Status closed => feedback
2016-11-30 15:02 Marcello Stanisci Resolution fixed => reopened
2016-11-30 15:03 Marcello Stanisci Note Added: 0011556
2016-11-30 15:04 Marcello Stanisci Note Added: 0011557
2016-12-02 17:00 Marcello Stanisci Status feedback => confirmed
2016-12-02 17:00 Marcello Stanisci Status confirmed => assigned
2016-12-07 14:26 Marcello Stanisci Priority normal => high
2016-12-08 17:25 Marcello Stanisci Status assigned => feedback
2016-12-08 17:25 Marcello Stanisci Note Added: 0011584
2016-12-08 17:26 Marcello Stanisci Priority high => normal
2018-01-30 08:36 Christian Grothoff Status feedback => closed
2018-01-30 08:36 Christian Grothoff Resolution reopened => fixed
2018-01-30 08:36 Christian Grothoff Note Added: 0012838