View Issue Details

IDProjectCategoryView StatusLast Update
0004639Talermerchant frontend (blog)public2016-10-11 17:28
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004639: merchant frontends do not work with strict CSP
Description... since in some cases, we dynamically generate JavaScript and inject it directly into the HTML.

Instead, the JavaScript should be static and parse values out of the DOM.
TagsNo tags attached.

Activities

Marcello Stanisci

2016-09-05 16:32

manager   ~0011089

donation shop adapted but not tested since the bank needs also to be adapted.

Florian Dold

2016-09-12 23:56

manager   ~0011112

Not tested yet (since we can't set headers until demo is upgraded), but we aren't using inline scripts or inline event handlers anymore.

Issue History

Date Modified Username Field Change
2016-09-05 13:35 Florian Dold New Issue
2016-09-05 16:32 Marcello Stanisci Note Added: 0011089
2016-09-12 23:56 Florian Dold Note Added: 0011112
2016-09-12 23:56 Florian Dold Status new => resolved
2016-09-12 23:56 Florian Dold Resolution open => fixed
2016-09-12 23:56 Florian Dold Assigned To => Florian Dold
2016-09-19 00:52 Christian Grothoff Product Version => 0.0
2016-09-19 00:52 Christian Grothoff Fixed in Version => 0.1
2016-09-19 00:52 Christian Grothoff Target Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed