View Issue Details

IDProjectCategoryView StatusLast Update
0004585Talerdeployment and operationspublic2016-11-20 03:26
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PriorityhighSeveritymajorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version0.0 
Target Version0.2Fixed in Version0.2 
Summary0004585: docker machine keeps dying
Description.. therefore breaking the autoclicking performed by buildbot-driven selenium
TagsNo tags attached.

Activities

Marcello Stanisci

2016-06-27 13:40

manager   ~0010934

changing to 'none' priority as it does not show this behaviour anymore.

Christian Grothoff

2016-07-09 17:25

manager   ~0010983

Ok, let's plan to resolve it with the 0.1 release unless it arises again.

Marcello Stanisci

2016-07-20 11:25

manager   ~0010990

It did not die, but the testcase itself (better, the container hosting chrome) now shows this erroneous behaviour:

Stacktrace:
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0 (NativeConstructorAccessorImpl.java:-2)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance (NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance (DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance (Constructor.java:423)
    at org.openqa.selenium.remote.ErrorHandler.createThrowable (ErrorHandler.java:206)
    at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed (ErrorHandler.java:158)
    at org.openqa.selenium.remote.RemoteWebDriver.execute (RemoteWebDriver.java:678)
    at org.openqa.selenium.remote.RemoteWebElement.execute (RemoteWebElement.java:327)
    at org.openqa.selenium.remote.RemoteWebElement.click (RemoteWebElement.java:85)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (NativeMethodAccessorImpl.java:-2)
    at sun.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke (Method.java:498)
    at org.openqa.selenium.support.events.EventFiringWebDriver$EventFiringWebElement$1.invoke (EventFiringWebDriver.java:335)
    at com.sun.proxy.$Proxy2.click (None:-1)
    at org.openqa.selenium.support.events.EventFiringWebDriver$EventFiringWebElement.click (EventFiringWebDriver.java:348)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (NativeMethodAccessorImpl.java:-2)
    at sun.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke (Method.java:498)
    at org.openqa.selenium.remote.server.KnownElements$1.invoke (KnownElements.java:64)
    at com.sun.proxy.$Proxy3.click (None:-1)
    at org.openqa.selenium.remote.server.handler.ClickElement.call (ClickElement.java:30)
    at org.openqa.selenium.remote.server.handler.ClickElement.call (ClickElement.java:1)
    at java.util.concurrent.FutureTask.run (FutureTask.java:266)
    at org.openqa.selenium.remote.server.DefaultSession$1.run (DefaultSession.java:176)
    at java.util.concurrent.ThreadPoolExecutor.runWorker (ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:617)
    at java.lang.Thread.run (Thread.java:745)

Marcello Stanisci

2016-11-07 17:34

manager   ~0011445

docker-machine SEEMS fine after updating virtualbox.

The master doesn't start with new configuration:

2016-11-07 17:29:46+0100 [-] error while parsing config file:
        Traceback (most recent call last):
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/python/threadpool.py", line 262, in <lambda>
            inContext.theWork = lambda: context.call(ctx, func, *args, **kw)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/python/context.py", line 118, in callWithContext
            return self.currentContext().callWithContext(ctx, func, *args, **kw)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/python/context.py", line 81, in callWithContext
            return func(*args,**kw)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/config.py", line 162, in loadConfig
            self.basedir, self.configFileName)
        --- <exception caught here> ---
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/config.py", line 119, in loadConfigDict
            exec(f, localDict)
          File "/home/containers/buildbot/master/master.cfg", line 69, in <module>
            builderNames=["global-switcher", "lcov-build", "auto-click"])
        exceptions.TypeError: __init__() got an unexpected keyword argument 'project'
        
2016-11-07 17:29:46+0100 [-] Configuration Errors:
2016-11-07 17:29:46+0100 [-] error while parsing config file: __init__() got an unexpected keyword argument 'project' (traceback in logfile)
2016-11-07 17:29:46+0100 [-] Halting master.
2016-11-07 17:29:46+0100 [-] BuildMaster startup failed
2016-11-07 17:29:46+0100 [-] BuildMaster is stopped
2016-11-07 17:29:46+0100 [-] Main loop terminated.
2016-11-07 17:29:46+0100 [-] Server Shut Down.
2016-11-07 17:31:17+0100 [-] Loading buildbot.tac...
2016-11-07 17:31:18+0100 [-] Loaded.
2016-11-07 17:31:18+0100 [-] twistd 16.5.0 (/home/containers/buildbot/venv/bin/python2 2.7.12) starting up.
2016-11-07 17:31:18+0100 [-] reactor class: twisted.internet.epollreactor.EPollReactor.
2016-11-07 17:31:18+0100 [-] Starting BuildMaster -- buildbot.version: 0.9.1
2016-11-07 17:31:18+0100 [-] Loading configuration from '/home/containers/buildbot/master/master.cfg'
2016-11-07 17:31:18+0100 [-] Configuration Errors:
2016-11-07 17:31:18+0100 [-] encountered a SyntaxError while parsing config file:
        Traceback (most recent call last):
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/config.py", line 119, in loadConfigDict
            exec(f, localDict)
          File "/home/containers/buildbot/master/master.cfg", line 71
            force-click = ForceScheduler(
        SyntaxError: can't assign to operator
         
2016-11-07 17:31:18+0100 [-] Halting master.
2016-11-07 17:31:18+0100 [-] BuildMaster startup failed
2016-11-07 17:31:18+0100 [-] BuildMaster is stopped
2016-11-07 17:31:18+0100 [-] Main loop terminated.
2016-11-07 17:31:18+0100 [-] Server Shut Down.

Marcello Stanisci

2016-11-07 23:21

manager   ~0011446

Porting to new 0.9.x API needs more work:

        Traceback (most recent call last):
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/internet/defer.py", line 1316, in gotResult
            _inlineCallbacks(r, g, deferred)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/internet/defer.py", line 1260, in _inlineCallbacks
            result = g.send(result)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/util/service.py", line 49, in reconfigServiceWithBuildbotConfig
            yield svc.reconfigServiceWithBuildbotConfig(new_config)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/internet/defer.py", line 1406, in unwindGenerator
            return _inlineCallbacks(None, gen, Deferred())
        --- <exception caught here> ---
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/twisted/internet/defer.py", line 1260, in _inlineCallbacks
            result = g.send(result)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/www/service.py", line 82, in reconfigServiceWithBuildbotConfig
            self.setupSite(new_config)
          File "/home/containers/buildbot/venv/local/lib/python2.7/site-packages/buildbot/www/service.py", line 139, in setupSite
            raise RuntimeError("could not find buildbot-www; is it installed?")
        exceptions.RuntimeError: could not find buildbot-www; is it installed?

Marcello Stanisci

2016-11-08 11:18

manager   ~0011447

Fixed by installing additional packages. The full suite is

- buildbot
- buildbot-worker
- buildbot-www
- buildbot-waterfall-view
- buildbot-console-view

Marcello Stanisci

2016-11-08 11:18

manager   ~0011448

Keep as 'feedback' to make sure docker-machine stays alive.

Marcello Stanisci

2016-11-13 20:32

manager   ~0011474

Error reported in msg 10990 was due to the way the wallet extension
was zipped before being sent to the browser. The fix was to zip it
using this facility from chromium itself, like
  
  $ xvfb-run chromium --pack-extension /path/to/wallet-webex

Marcello Stanisci

2016-11-13 20:35

manager   ~0011475

Updating virtualbox seems to have fixed this.

Issue History

Date Modified Username Field Change
2016-06-21 16:04 Marcello Stanisci New Issue
2016-06-21 16:04 Marcello Stanisci Status new => assigned
2016-06-21 16:04 Marcello Stanisci Assigned To => Marcello Stanisci
2016-06-27 13:40 Marcello Stanisci Priority normal => none
2016-06-27 13:40 Marcello Stanisci Note Added: 0010934
2016-07-09 17:25 Christian Grothoff Note Added: 0010983
2016-07-09 17:25 Christian Grothoff Reproducibility always => unable to reproduce
2016-07-09 17:25 Christian Grothoff Product Version => 0.0
2016-07-09 17:25 Christian Grothoff Target Version => 0.1
2016-07-20 11:25 Marcello Stanisci Note Added: 0010990
2016-09-27 22:29 Christian Grothoff Target Version 0.1 => 0.2
2016-09-27 22:31 Christian Grothoff Priority none => normal
2016-10-10 08:29 Christian Grothoff Target Version 0.2 => 0.5
2016-11-07 09:57 Marcello Stanisci Priority normal => high
2016-11-07 17:34 Marcello Stanisci Note Added: 0011445
2016-11-07 23:21 Marcello Stanisci Note Added: 0011446
2016-11-08 11:18 Marcello Stanisci Note Added: 0011447
2016-11-08 11:18 Marcello Stanisci Note Added: 0011448
2016-11-08 11:18 Marcello Stanisci Status assigned => feedback
2016-11-13 20:32 Marcello Stanisci Note Added: 0011474
2016-11-13 20:35 Marcello Stanisci Status feedback => resolved
2016-11-13 20:35 Marcello Stanisci Resolution open => fixed
2016-11-13 20:35 Marcello Stanisci Note Added: 0011475
2016-11-15 00:38 root Fixed in Version => 0.2
2016-11-15 00:38 root Target Version 0.5 => 0.2
2016-11-20 03:26 Christian Grothoff Status resolved => closed