View Issue Details

IDProjectCategoryView StatusLast Update
0004584Talerwallet (WebExtensions)public2016-10-11 17:28
ReporterMarcello StanisciAssigned ToFlorian Dold 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004584: /reserve/status request to wrong base URL
DescriptionGET /reserve/status?reserve_pub=1BXVBJ27MWPG4B782MR2V6WMZKJ60GDMN6MQA15W5P2WXPE8JKT0 HTTP/1.1" 404 65 "-"

The request is apparently sent to http://taler.net instead of http://exchange.*,
so there might be some error in the wallet
TagsNo tags attached.

Activities

Florian Dold

2016-09-26 18:22

manager   ~0011178

I can't reproduce this issue. Is this taken from the logs on taler.net? Where?

Marcello Stanisci

2016-09-27 10:01

manager   ~0011182

Last edited: 2016-09-27 10:01

View 2 revisions

grep for 1BXV in /var/log/nginx/access.log on tripwire. There are plenty of them, and apparently they keep growing, although no docker is running from the 'container' user..

Marcello Stanisci

2016-09-27 10:04

manager   ~0011183

There's more: /var/log/nginx/access.log seems to contain mostly these wrong GET /reserve/status requests

Florian Dold

2016-09-28 19:53

manager   ~0011194

The requests for exchange.{demo,test}.taler.net also show up in the nginx access log.

These messages are just normal accesses to the reserve status. The 404 just appears because this comes from wallets.

To "prove" this (and to improve logging in general ;-) ) I've added the $host to the nginx log. In future log lines, the host is always recorded.

Issue History

Date Modified Username Field Change
2016-06-20 18:29 Marcello Stanisci New Issue
2016-06-20 18:29 Marcello Stanisci Status new => assigned
2016-06-20 18:29 Marcello Stanisci Assigned To => Florian Dold
2016-06-20 18:29 Marcello Stanisci Product Version => 0.0
2016-06-20 18:29 Marcello Stanisci Target Version => 0.1
2016-09-26 18:01 Florian Dold Status assigned => resolved
2016-09-26 18:01 Florian Dold Resolution open => fixed
2016-09-26 18:21 Florian Dold Status resolved => assigned
2016-09-26 18:22 Florian Dold Note Added: 0011178
2016-09-26 18:22 Florian Dold Status assigned => feedback
2016-09-27 10:01 Marcello Stanisci Note Added: 0011182
2016-09-27 10:01 Marcello Stanisci Status feedback => assigned
2016-09-27 10:01 Marcello Stanisci Note Edited: 0011182 View Revisions
2016-09-27 10:04 Marcello Stanisci Note Added: 0011183
2016-09-28 19:53 Florian Dold Note Added: 0011194
2016-09-28 19:53 Florian Dold Status assigned => resolved
2016-09-28 23:30 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed