View Issue Details

IDProjectCategoryView StatusLast Update
0004575Talerdeployment and operationspublic2016-10-11 17:28
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.1 
Target Version0.1Fixed in Version0.1 
Summary0004575: concerning 404s in the nginx log on taler.net
Description"GET /web-common/taler-wallet-lib.js HTTP/1.1" 404 136 "https://taler.net/wallet-installation.html"

/robots.txt
/favicon.ico
/static/web-common/taler-presence.js from https://bank.demo.taler.net/profile

GET /web-common/taler-wallet-lib.js HTTP/1.1" 404 193 "https://taler.net/wallet-installation.html

Plus tons of:
GET /reserve/status?reserve_pub=1BXVBJ27MWPG4B782MR2V6WMZKJ60GDMN6MQA15W5P2WXPE8JKT0 HTTP/1.1" 404 65 "-"
(bad hostname?)

We should figure out where they come from and fix them (by either fixing the link or providing the resources in the expected location).
TagsNo tags attached.

Activities

Marcello Stanisci

2016-06-20 18:23

manager   ~0010916

1) The error:

"GET /web-common/taler-wallet-lib.js HTTP/1.1" 404 136 "https://taler.net/wallet-installation.html" [^]

was due to an outdated version of the 'web-common' git submodule employed in the 'www' repo, and has been fixed.

2) The error:

 /static/web-common/taler-presence.js from https://bank.demo.taler.net/profile [^]

was due to an obsolete include in the bank, which has been fixed but is still erroneous in the 'demo' deployment because it points to older commits.

Every other website now fetches favicon.ico and robots.txt from /var/www/favicon_robots

Issue History

Date Modified Username Field Change
2016-06-10 16:15 Christian Grothoff New Issue
2016-06-10 16:15 Christian Grothoff Status new => assigned
2016-06-10 16:15 Christian Grothoff Assigned To => Marcello Stanisci
2016-06-20 18:23 Marcello Stanisci Note Added: 0010916
2016-06-20 18:23 Marcello Stanisci Status assigned => resolved
2016-06-20 18:23 Marcello Stanisci Resolution open => fixed
2016-06-20 19:04 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed