View Issue Details

IDProjectCategoryView StatusLast Update
0004572Talerdeployment and operationspublic2016-10-11 17:28
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004572: benchmark simply does not return
Descriptionafter doing all the operations, and when the fail() function is called,
the command just doesn't return and must be killed by CTRL-C. Furthermore,
when fail() is invoked, the exchange's process does not get killed
TagsNo tags attached.

Activities

Christian Grothoff

2016-06-09 16:08

manager   ~0010882

Is this still an issue?

Marcello Stanisci

2016-06-09 23:59

manager   ~0010884

Yes.

Notice that this is not about CTRL-C that hangs, instead it is about the program itself that does not return, but CTRL-C does kill it.

To make things more interesting, I also sometimes get the following now when killing:

*** Error in `taler-exchange-benchmark': corrupted double-linked list: 0x09ddfe30 ***

Christian Grothoff

2016-06-10 00:03

manager   ~0010885

If it exits nicely on CTRL-C, you're likely missing a call to GNUNET_SCHEDULER_shutdown() upon completion of the benchmark.

For the corrupted DLL, you should run the program under valgrind to see where the heap is being corrupted.

Marcello Stanisci

2016-06-11 16:34

manager   ~0010889

fixed in 06622fb..44f2ac5. The problem was that the shutdown routine did not terminate the exchange process, so the statement GNUNET_OS_process_wait(..) called in the main function used to wait indefinitely

Issue History

Date Modified Username Field Change
2016-06-08 15:11 Marcello Stanisci New Issue
2016-06-08 15:11 Marcello Stanisci Status new => assigned
2016-06-08 15:11 Marcello Stanisci Assigned To => Marcello Stanisci
2016-06-09 16:08 Christian Grothoff Note Added: 0010882
2016-06-09 23:59 Marcello Stanisci Note Added: 0010884
2016-06-10 00:03 Christian Grothoff Note Added: 0010885
2016-06-11 16:34 Marcello Stanisci Note Added: 0010889
2016-06-11 16:34 Marcello Stanisci Status assigned => resolved
2016-06-11 16:34 Marcello Stanisci Resolution open => fixed
2016-06-11 21:35 Christian Grothoff Product Version => 0.0
2016-06-11 21:35 Christian Grothoff Fixed in Version => 0.1
2016-06-11 21:35 Christian Grothoff Target Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed