View Issue Details

IDProjectCategoryView StatusLast Update
0004546GNUnetARM servicepublic2018-06-07 00:24
ReporterlynXAssigned ToChristian Grothoff 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004546: GLOBAL_POSTFIX not added when OPTIONS is set
DescriptionGLOBAL_POSTFIX is not added to the command-line options if a per-service OPTIONS is set. It'd be desireable to either always add GLOBAL_POSTFIX or have a variant of it that is always added.

///

When using GLOBAL_POSTFIX = -l $GNUNET_CACHE_HOME/{}-%Y-%m-%d.log as
suggested by some configurations, only some services write to such
individual logs. Others still gladly send all of their output to the
main log that was provided to gnunet-arm.

https://gnunet.org/bugs/view.php?id=4542#c10785 shows an example of how
the unglobality of GLOBAL_POSTFIX needs to be circumvented.

TagsNo tags attached.

Activities

tg

2016-05-31 22:21

manager   ~0010824

updated description

Christian Grothoff

2016-06-01 22:01

manager   ~0010841

Should be fixed in SVN 37226 (but not extensively tested).

tg

2016-06-02 00:30

manager   ~0010846

just tested, GLOBAL_POSTFIX is now added after OPTIONS,
however it would make sense to do it the otherway around:
first GLOBAL_OPTIONS (actually this is a better name for it) then OPTIONS

this results in OPTIONS being able to
- override GLOBAL_OPTIONS (getopt takes the last one out of multiple options with the same name)
- add additional non-switch arguments at the end

also, possibly due to this change or the one for 0004545,
var expansion does not work anymore, see 0004555

lynX

2016-06-02 17:04

developer   ~0010848

tg, we reported this *because* it was behaving the way you are suggesting.. right? While I am fine with a GLOBAL_OPTIONS setting, that is indeed applied to all services (I like the name, if it is more accurate), you would want something more which would be more appropriate to call "DEFAULT_OPTIONS" as the word 'default' makes it clear that it likes to be overridden. Not that I needed such a feature, but if you want it...

Christian Grothoff

2016-06-02 17:13

manager   ~0010849

Option order inverted in SVN 37235.

Issue History

Date Modified Username Field Change
2016-05-31 18:11 lynX New Issue
2016-05-31 22:20 tg Summary GLOBAL_POSTFIX inconsistently honored (not as global as expected) => GLOBAL_POSTFIX not added when OPTIONS is set
2016-05-31 22:20 tg Description Updated View Revisions
2016-05-31 22:21 tg Note Added: 0010824
2016-05-31 22:26 tg Description Updated View Revisions
2016-06-01 14:32 lynX Description Updated View Revisions
2016-06-01 14:35 lynX Description Updated View Revisions
2016-06-01 19:12 Christian Grothoff Assigned To => Christian Grothoff
2016-06-01 19:12 Christian Grothoff Status new => assigned
2016-06-01 19:12 Christian Grothoff Target Version => 0.11.0pre66
2016-06-01 22:01 Christian Grothoff Note Added: 0010841
2016-06-01 22:01 Christian Grothoff Status assigned => resolved
2016-06-01 22:01 Christian Grothoff Fixed in Version => 0.11.0pre66
2016-06-01 22:01 Christian Grothoff Resolution open => fixed
2016-06-02 00:30 tg Note Added: 0010846
2016-06-02 17:04 lynX Note Added: 0010848
2016-06-02 17:04 lynX Status resolved => feedback
2016-06-02 17:04 lynX Resolution fixed => reopened
2016-06-02 17:13 Christian Grothoff Note Added: 0010849
2016-06-02 17:13 Christian Grothoff Status feedback => resolved
2016-06-02 17:13 Christian Grothoff Resolution reopened => fixed
2018-06-07 00:24 Christian Grothoff Status resolved => closed