View Issue Details

IDProjectCategoryView StatusLast Update
0004545GNUnetutil librarypublic2018-06-07 00:24
ReporterlynXAssigned ToChristian Grothoff 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0004545: GNUNET_CACHE_HOME directory may not exist
Descriptioncomputer] rgrep GNUNET_CACHE_HOME
./util/util.conf
GNUNET_CACHE_HOME = ${XDG_CACHE_HOME:-$GNUNET_HOME/.cache}/gnunet/

./nse/nse.conf
HISTOGRAM_DIR = $GNUNET_CACHE_HOME/nse/histogram

./nse/nse.conf.in
HISTOGRAM_DIR = $GNUNET_CACHE_HOME/nse/histogram

./arm/arm.conf
# GLOBAL_POSTFIX = -l $GNUNET_CACHE_HOME/{}-%Y-%m-%d.log

./arm/arm.conf.in
# GLOBAL_POSTFIX = -l $GNUNET_CACHE_HOME/{}-%Y-%m-%d.log


Apparently some services define and use a macro called
GNUNET_CACHE_HOME, yet they do not make sure such a
directory even exists. By consequence, my gnunet.log now
looks like this:

May 30 19:06:50-684030 revocation-31179 ERROR `open' failed on file `/home/gnunet/.cache/gnunet//revocation-2016-05-30.log' at common_logging.c:392 with error: No such file or directory
May 30 19:06:50-804175 gnunet-daemon-topology-31180 ERROR `open' failed on file `/home/gnunet/.cache/gnunet//topology-2016-05-30.log' at common_logging.c:392 with error: No such file or directory
May 30 19:06:50-861711 gnunet-daemon-exit-31182 ERROR `open' failed on file `/home/gnunet/.cache/gnunet//exit-2016-05-30.log' at common_logging.c:392 with error: No such file or directory
May 30 19:06:50-863805 fs-31181 ERROR `open' failed on file `/home/gnunet/.cache/gnunet//fs-2016-05-30.log' at common_logging.c:392 with error: No such file or directory
May 30 19:07:16-932868 core-31183 ERROR `open' failed on file `/home/gnunet/.cache/gnunet//core-2016-05-30.log' at common_logging.c:392 with error: No such file or directory

Also, why the double-slash?

computer] grep -c common_logging /home/gnunet/gnunet.log
152

The log is 10 minutes old, and already contains 152 errors because of that.
Not surprising gnunet doesn't run extremely fast on some systems....

I could fix the bug somewhere, but I'm not sure where it makes sense the most.
We don't want to check for existing dirs at every logging operation...
TagsNo tags attached.

Activities

tg

2016-05-31 22:18

manager   ~0010823

Last edited: 2016-05-31 22:26

View 2 revisions

updated description

lynX

2016-06-01 14:27

developer   ~0010832

Last edited: 2016-06-01 14:30

View 2 revisions

Actually you added the description of a different and a lot less important bug. Cleaning this up now.

Christian Grothoff

2016-06-01 19:09

manager   ~0010834

Fixed in SVN 37223.

tg

2016-06-02 00:32

manager   ~0010847

now the directory is created but var expansion does not work anymore, see 0004555

Issue History

Date Modified Username Field Change
2016-05-30 19:21 lynX New Issue
2016-05-30 19:21 lynX Status new => assigned
2016-05-30 19:21 lynX Assigned To => Christian Grothoff
2016-05-31 00:57 Christian Grothoff Priority normal => high
2016-05-31 00:57 Christian Grothoff Target Version => 0.11.0pre66
2016-05-31 22:18 tg Note Added: 0010823
2016-05-31 22:26 tg Summary GNUNET_CACHE_HOME does not exist => config var-expansion does not always work
2016-05-31 22:26 tg Description Updated View Revisions
2016-05-31 22:26 tg Note Edited: 0010823 View Revisions
2016-05-31 22:28 tg Description Updated View Revisions
2016-06-01 14:27 lynX Note Added: 0010832
2016-06-01 14:30 lynX Summary config var-expansion does not always work => GNUNET_CACHE_HOME directory may not exist
2016-06-01 14:30 lynX Description Updated View Revisions
2016-06-01 14:30 lynX Note Edited: 0010832 View Revisions
2016-06-01 19:09 Christian Grothoff Note Added: 0010834
2016-06-01 19:09 Christian Grothoff Status assigned => resolved
2016-06-01 19:09 Christian Grothoff Fixed in Version => 0.11.0pre66
2016-06-01 19:09 Christian Grothoff Resolution open => fixed
2016-06-02 00:32 tg Note Added: 0010847
2018-06-07 00:24 Christian Grothoff Status resolved => closed