View Issue Details

IDProjectCategoryView StatusLast Update
0004510Talerdeployment and operationspublic2016-10-11 17:28
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PriorityhighSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004510: integrate selenium test with buildbot
DescriptionThe selenium tests should be run regularly for {demo,test} via buildbot.

Specifically, the containers@taler.net (or fournier, for the moment) user should have a buildslave.
TagsNo tags attached.

Activities

Marcello Stanisci

2016-06-20 18:37

manager   ~0010917

the manual rebuild used to fail because TALER_CHECKDB was unsed but (strangely) buildbot did not complain about that. Check this!
among the other things, it's not clear which slave actually sends output to the buildbot waterfall

Marcello Stanisci

2016-06-20 22:32

manager   ~0010918

Not all the slaves are run at each build:
http://stackoverflow.com/questions/2229481/what-algorithm-does-buildbot-use-to-assign-builders-to-slaves

Marcello Stanisci

2016-06-20 23:48

manager   ~0010919

problems using nextSlave parameter when instantiating BuilderConfig(...)

Marcello Stanisci

2016-06-21 15:56

manager   ~0010920

implemented by 253d441efc (deployment repo). the test does not still pass due to the docker virtual machine that periodically dies.

Issue History

Date Modified Username Field Change
2016-05-20 11:28 Florian Dold New Issue
2016-05-20 15:26 Christian Grothoff Severity minor => feature
2016-05-20 15:26 Christian Grothoff Status new => confirmed
2016-05-20 15:26 Christian Grothoff Product Version => 0.0
2016-05-20 15:26 Christian Grothoff Target Version => 0.2
2016-06-06 20:21 Florian Dold Assigned To => Marcello Stanisci
2016-06-06 20:21 Florian Dold Priority normal => high
2016-06-06 20:21 Florian Dold Target Version 0.2 => 0.1
2016-06-06 20:21 Florian Dold Description Updated View Revisions
2016-06-20 18:37 Marcello Stanisci Note Added: 0010917
2016-06-20 22:32 Marcello Stanisci Note Added: 0010918
2016-06-20 23:48 Marcello Stanisci Note Added: 0010919
2016-06-21 15:56 Marcello Stanisci Note Added: 0010920
2016-06-21 15:56 Marcello Stanisci Status confirmed => resolved
2016-06-21 15:56 Marcello Stanisci Resolution open => fixed
2016-09-26 13:52 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed