View Issue Details

IDProjectCategoryView StatusLast Update
0004495TalerWeb site(s)public2016-05-09 18:34
ReporterTorsten GrothoffAssigned ToFlorian Dold 
PriorityimmediateSeverityblockReproducibilityhave not tried
Status closedResolutionnot fixable 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.0 
Target Version0.0Fixed in Version0.0 
Summary0004495: fulfillment page fails(400)
Descriptionhttps://shop.demo.taler.net/fulfillment?uuid=YGZ5DEZY8PY2HB1MSCK26RVVEWCTSEWX9TAA85XB45CTAGANECTBFK06GKE1KQV16SK6Q87HAJWNFXSE6Z1A1KMEHN2YWFZHZ6GG1W8&receiver=GNUnet&aval=10&timestamp=1462774148&tid=386032523005631&afrac=0&acurr=KUDOS
TagsNo tags attached.

Relationships

related to 0004497 closedChristian Grothoff revise error responses 
related to 0004219 closedMarcello Stanisci infrastructure for headless selenium tests on taler.net missing 
has duplicate 0004494 closedFlorian Dold fulfillment page fails(502) 
related to 0004496 closedMarcello Stanisci logging is missing crucial information 

Activities

Florian Dold

2016-05-09 08:35

manager   ~0010667

Last edited: 2016-05-09 08:40

View 2 revisions

According to the logs: May 09 08:03:17-376350 taler-merchant-httpd-6244 WARNING External protocol violation detected at taler-merchant-httpd_pay.c:440.

This is clearly an instance of 0004475. The merchant does not give an appropriate error response though (a status code with a "bad request" and "hint" but no "error" is not enough ...)

I'm not sure what we can do here (except improve logging via 0004496 and error reporting via 0004497 and of course fixing 0004475).

Florian Dold

2016-05-09 08:39

manager   ~0010668

Last edited: 2016-05-09 08:40

View 2 revisions

Resolving this, since besides the related bugs I mentioned earlier there's nothing we can do directly, Torsten's wallet has "faulty" keys because the exchange screwed up at some point.

Florian Dold

2016-05-09 08:43

manager   ~0010669

Also, issues like this are why I'd like to see 0004219 resolved.

This is not something where we want to wait for users to try out our demo, the bot should do that, and open a bug or send out an email.

Christian Grothoff

2016-05-09 09:45

manager   ~0010671

We might want to improve the error message...

Florian Dold

2016-05-09 09:46

manager   ~0010672

Yeah, definitely. See related bugs ;-)

Issue History

Date Modified Username Field Change
2016-05-09 08:13 Christian Grothoff New Issue
2016-05-09 08:13 Christian Grothoff Status new => assigned
2016-05-09 08:13 Christian Grothoff Assigned To => Florian Dold
2016-05-09 08:13 Christian Grothoff Reporter Christian Grothoff => Torsten Grothoff
2016-05-09 08:27 Florian Dold Relationship added related to 0004496
2016-05-09 08:28 Florian Dold Relationship added has duplicate 0004494
2016-05-09 08:33 Florian Dold Relationship added related to 0004497
2016-05-09 08:35 Florian Dold Note Added: 0010667
2016-05-09 08:39 Florian Dold Note Added: 0010668
2016-05-09 08:39 Florian Dold Status assigned => resolved
2016-05-09 08:39 Florian Dold Resolution open => not fixable
2016-05-09 08:40 Florian Dold Note Edited: 0010668 View Revisions
2016-05-09 08:40 Florian Dold Note Edited: 0010667 View Revisions
2016-05-09 08:41 Florian Dold Relationship added related to 0004219
2016-05-09 08:43 Florian Dold Note Added: 0010669
2016-05-09 09:45 Christian Grothoff Note Added: 0010671
2016-05-09 09:46 Florian Dold Note Added: 0010672
2016-05-09 18:34 Christian Grothoff Status resolved => closed
2016-05-09 18:34 Christian Grothoff Fixed in Version => 0.0