View Issue Details

IDProjectCategoryView StatusLast Update
0004395Talerdeployment and operationspublic2016-10-11 17:28
ReporterChristian GrothoffAssigned ToMarcello Stanisci 
PriorityurgentSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004395: integrate taler-exchange-aggregator with demo and test deployments
DescriptionThe taler-exchange-aggregator now (see 0004141) passes its testcases. It should thus be able to aggregate and trigger the execution of outgoing wire transfers from the exchange.

We should run it (as an additional process, alongside the taler-exchange-httpd) on the demo and test installations to actually wire payments (donations/shop) received into the FSF/Tor/GNUnet/Taler accounts, so that the actual KUDOS/PUDOS donated do show up properly on the receiving side in the public accounts (and that the correct amounts are actually withdrawn from the exchange).

With this, we should really see the full bank balances shift properly in the bank according to the "economic" activity of the demonstrator. This bug should be considered "resolved" if the aggregator is running AND working with the bank, effectively obsoleting the filling of the bank accounts with "dummy" transactions.
TagsNo tags attached.

Relationships

related to 0004539 closedMarcello Stanisci {test,demo} setup should have one backend per donation receiver 
related to 0004540 closedMarcello Stanisci donation frontend should support one backend per receiver 

Activities

Marcello Stanisci

2016-05-22 20:45

manager   ~0010702

It's been a while that 'arm' calls the aggregator

Christian Grothoff

2016-05-26 14:09

manager   ~0010763

If the aggregator is running, something else is still wrong, because if I look at the history of public accounts, I do not see incoming transactions for fsf/tor/gnunet/taler. But if the aggregator were properly integrated (and if the execution date is set properly!), then I should see incoming transactions.

Marcello Stanisci

2016-06-28 16:55

manager   ~0010942

bank does not complain about non existent accounts..

Marcello Stanisci

2016-06-29 18:06

manager   ~0010945

manually invoking taler-exchange-aggregator works, so it'll work as well via 'arm' invocation. The only thing is that although we have

[merchant]
WIRE_TRANSFER_DELAY = 1 m

the aggregator took 1 day to execute the wiretransfers (yesterday it did not find any wiretransfer to accomplish). There seems to be no other time-ish configuration value around tough.

Christian Grothoff

2016-06-29 18:28

manager   ~0010946

Let's try to understand this better, it should really take 1m.

Marcello Stanisci

2016-06-30 14:01

manager   ~0010948

by setting refund_deadline to "now" in donations frontend it is possible to lively see wire transfers.

Issue History

Date Modified Username Field Change
2016-04-10 14:34 Christian Grothoff New Issue
2016-04-10 14:34 Christian Grothoff Status new => assigned
2016-04-10 14:34 Christian Grothoff Assigned To => Marcello Stanisci
2016-05-22 20:45 Marcello Stanisci Note Added: 0010702
2016-05-22 20:45 Marcello Stanisci Status assigned => resolved
2016-05-22 20:45 Marcello Stanisci Resolution open => fixed
2016-05-24 20:51 Christian Grothoff Fixed in Version => 0.0
2016-05-24 20:51 Christian Grothoff Target Version 0.1 => 0.0
2016-05-26 14:09 Christian Grothoff Note Added: 0010763
2016-05-26 14:09 Christian Grothoff Status resolved => assigned
2016-05-26 17:42 Florian Dold Relationship added related to 0004539
2016-05-26 17:42 Florian Dold Relationship added related to 0004540
2016-05-31 01:11 Christian Grothoff Fixed in Version 0.0 =>
2016-05-31 01:11 Christian Grothoff Target Version 0.0 => 0.1
2016-06-28 16:55 Marcello Stanisci Note Added: 0010942
2016-06-29 18:06 Marcello Stanisci Note Added: 0010945
2016-06-29 18:06 Marcello Stanisci Status assigned => resolved
2016-06-29 18:28 Christian Grothoff Note Added: 0010946
2016-06-29 18:28 Christian Grothoff Status resolved => assigned
2016-06-30 14:01 Marcello Stanisci Note Added: 0010948
2016-06-30 14:01 Marcello Stanisci Status assigned => resolved
2016-06-30 20:51 Christian Grothoff Fixed in Version => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed